aboutsummaryrefslogtreecommitdiffstats
path: root/lang/p5-Parse-Perl/Makefile
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:20:58 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:20:58 +0800
commit52fd353b686d7b7fbb1e098ad2d4ee88a8223f47 (patch)
tree7d6f9a9078930c4a13be1154fc4cbe4c1d8eedd8 /lang/p5-Parse-Perl/Makefile
parent73579f3a21babfd2dbd2b878bf9e284eb4e64bb1 (diff)
downloadfreebsd-ports-gnome-52fd353b686d7b7fbb1e098ad2d4ee88a8223f47.tar.gz
freebsd-ports-gnome-52fd353b686d7b7fbb1e098ad2d4ee88a8223f47.tar.zst
freebsd-ports-gnome-52fd353b686d7b7fbb1e098ad2d4ee88a8223f47.zip
This module provides the capability to parse a string at runtime as
Perl source code, so that the resulting compiled code can be later executed. This is part of the job of the string form of the eval operator, but in this module it is separated out from the other jobs of eval. Parsing of Perl code is generally influenced by its lexical context, and this module provides some explicit control over this process, by reifying lexical environments as Perl objects. WWW: http://search.cpan.org/dist/Parse-Perl/ PR: ports/152447 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'lang/p5-Parse-Perl/Makefile')
-rw-r--r--lang/p5-Parse-Perl/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/lang/p5-Parse-Perl/Makefile b/lang/p5-Parse-Perl/Makefile
new file mode 100644
index 000000000000..bd3dbf2dd907
--- /dev/null
+++ b/lang/p5-Parse-Perl/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Parse-Perl
+# Date created: 2010-11-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-Perl
+PORTVERSION= 0.005
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Interpret string as Perl source
+
+PERL_CONFIGURE= yes
+USE_PERL5_RUN= 5.8.4+
+
+MAN3= Parse::Perl.3 \
+ Parse::Perl::CopHintsHash.3 \
+ Parse::Perl::Environment.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>