aboutsummaryrefslogtreecommitdiffstats
path: root/lang/p5-Perl6-Subs/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2006-01-08 07:57:34 +0800
committertobez <tobez@FreeBSD.org>2006-01-08 07:57:34 +0800
commit4e89f3412ffb8934f525f40a2b136c5e96062831 (patch)
treebd926e276dca87bcad4f6535d7797902ce66f3b3 /lang/p5-Perl6-Subs/Makefile
parent9fc9d0001db2412851f1247460ddff55ebd9acd6 (diff)
downloadfreebsd-ports-gnome-4e89f3412ffb8934f525f40a2b136c5e96062831.tar.gz
freebsd-ports-gnome-4e89f3412ffb8934f525f40a2b136c5e96062831.tar.zst
freebsd-ports-gnome-4e89f3412ffb8934f525f40a2b136c5e96062831.zip
Add lang/p5-Perl6-Subs 0.05, a source filter that adds a very useful
subset of Perl 6 subroutine syntax to Perl 5.
Diffstat (limited to 'lang/p5-Perl6-Subs/Makefile')
-rw-r--r--lang/p5-Perl6-Subs/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/p5-Perl6-Subs/Makefile b/lang/p5-Perl6-Subs/Makefile
new file mode 100644
index 000000000000..6eefd15ff1ec
--- /dev/null
+++ b/lang/p5-Perl6-Subs/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: lang/p5-Perl6-Subs
+# Date created: 07 January 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl6-Subs
+PORTVERSION= 0.05
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Perl6
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl6::Subs - Define your subroutines in the Perl 6 style
+
+BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
+ ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Perl6::Subs.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500804
+IGNORE= requires perl 5.8.4 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>