aboutsummaryrefslogtreecommitdiffstats
path: root/lang/p5-signatures
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2009-08-04 19:36:50 +0800
committertobez <tobez@FreeBSD.org>2009-08-04 19:36:50 +0800
commit274d82ef9a175d787f5feac206578d68348e4a22 (patch)
treec73d1d46bc58696aec07e925e610ff40638ddf5a /lang/p5-signatures
parent48e73bf1e327dad8166cde56fc3ddfc132f8c3f6 (diff)
downloadfreebsd-ports-gnome-274d82ef9a175d787f5feac206578d68348e4a22.tar.gz
freebsd-ports-gnome-274d82ef9a175d787f5feac206578d68348e4a22.tar.zst
freebsd-ports-gnome-274d82ef9a175d787f5feac206578d68348e4a22.zip
Add lang/p5-signatures 0.06, a Perl module that brings subroutine
signatures into the language.
Diffstat (limited to 'lang/p5-signatures')
-rw-r--r--lang/p5-signatures/Makefile29
-rw-r--r--lang/p5-signatures/distinfo3
-rw-r--r--lang/p5-signatures/pkg-descr4
-rw-r--r--lang/p5-signatures/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/lang/p5-signatures/Makefile b/lang/p5-signatures/Makefile
new file mode 100644
index 000000000000..e92772b9af5a
--- /dev/null
+++ b/lang/p5-signatures/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: lang/p5-signatures
+# Date created: 04 August 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= signatures
+PORTVERSION= 0.06
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/F/FL/FLORA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Subroutine signatures for Perl with no source filter
+
+BUILD_DEPENDS= p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
+ p5-B-Hooks-Parser>=0.07:${PORTSDIR}/devel/p5-B-Hooks-Parser \
+ p5-B-Hooks-OP-PPAddr>0:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr \
+ p5-ExtUtils-Depends>=0.302:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= signatures.3
+
+.include <bsd.port.mk>
diff --git a/lang/p5-signatures/distinfo b/lang/p5-signatures/distinfo
new file mode 100644
index 000000000000..3f0df0b822e1
--- /dev/null
+++ b/lang/p5-signatures/distinfo
@@ -0,0 +1,3 @@
+MD5 (signatures-0.06.tar.gz) = af55428a1fcc2c3a7e8d3983db95cff7
+SHA256 (signatures-0.06.tar.gz) = 6375598efb6c468f2f463799072e08c4abfeaeb905cab084607955c907816eb8
+SIZE (signatures-0.06.tar.gz) = 63557
diff --git a/lang/p5-signatures/pkg-descr b/lang/p5-signatures/pkg-descr
new file mode 100644
index 000000000000..3be91a7e5ec4
--- /dev/null
+++ b/lang/p5-signatures/pkg-descr
@@ -0,0 +1,4 @@
+With this Perl module, you can specify subroutine signatures and have
+variables automatically defined within the subroutine.
+
+WWW: http://search.cpan.org/dist/signatures/
diff --git a/lang/p5-signatures/pkg-plist b/lang/p5-signatures/pkg-plist
new file mode 100644
index 000000000000..b265b92449b2
--- /dev/null
+++ b/lang/p5-signatures/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/signatures/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/signatures/signatures.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/signatures/signatures.so
+%%SITE_PERL%%/%%PERL_ARCH%%/signatures.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/signatures