aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5-devel/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-03-21 19:33:13 +0800
committermat <mat@FreeBSD.org>2017-03-21 19:33:13 +0800
commitc3bdd014ab24845226bda1b9d0de20adce5fcc5c (patch)
tree7dc67910782dd5275a010457c94abf7cec8c7e62 /lang/perl5-devel/Makefile
parent576965c59e8547ca09576d444dddc34d180918b2 (diff)
downloadfreebsd-ports-gnome-c3bdd014ab24845226bda1b9d0de20adce5fcc5c.tar.gz
freebsd-ports-gnome-c3bdd014ab24845226bda1b9d0de20adce5fcc5c.tar.zst
freebsd-ports-gnome-c3bdd014ab24845226bda1b9d0de20adce5fcc5c.zip
Add a DOT_INC option to allow people to build unsafe versions of Perl
with '.' in @INC. Sponsored by: Absolight
Diffstat (limited to 'lang/perl5-devel/Makefile')
-rw-r--r--lang/perl5-devel/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/perl5-devel/Makefile b/lang/perl5-devel/Makefile
index 784bd5be2770..b1fd98e63546 100644
--- a/lang/perl5-devel/Makefile
+++ b/lang/perl5-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= perl
-PORTREVISION= 0
+PORTREVISION= 1
# XXX Remove second line, uncomment first
#DISTVERSION= ${PERL_VERSION}
DISTVERSION= ${GH_TAGNAME:C/^v//:C/-g[0-9a-f]*$//}
@@ -39,7 +39,7 @@ GH_TAGNAME= v5.25.10-90-gffb91b6
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DEBUG GDBM PERL_64BITINT MULTIPLICITY SITECUSTOMIZE \
- THREADS PERL_MALLOC DTRACE
+ THREADS PERL_MALLOC DTRACE DOT_INC
OPTIONS_DEFAULT= PERL_64BITINT THREADS MULTIPLICITY DTRACE
OPTIONS_EXCLUDE_FreeBSD_10= DTRACE
@@ -58,6 +58,7 @@ PERL_64BITINT_DESC= Use 64 bit integers (on i386)
THREADS_DESC= Build threaded perl
MULTIPLICITY_DESC= Use multiplicity
SITECUSTOMIZE_DESC= Run-time customization of @INC
+DOT_INC_DESC= Add '.' to @INC (unsafe)
OPTIONS_SUB= yes
DEBUG_CONFIGURE_ON= -Doptimize="-g" -DDEBUGGING
@@ -75,6 +76,7 @@ THREADS_CONFIGURE_ON= -Dusethreads=y
THREADS_CONFIGURE_OFF= -Dusethreads=n
PERL_MALLOC_CONFIGURE_ON= -Dusemymalloc=y
PERL_MALLOC_CONFIGURE_OFF= -Dusemymalloc=n
+DOT_INC_CONFIGURE_ON= -Ddefault_inc_excludes_dot=n
# XXX uncomment PORTSCOUT line
#PORTSCOUT= limit:^${PERL_VER}.