aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.10
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-03-01 16:54:11 +0800
committerobrien <obrien@FreeBSD.org>2004-03-01 16:54:11 +0800
commitc7b39a003d5baaa63d5625b4499bd4897c87ff8d (patch)
tree0a3c8a30e573cd978ee1d75a65d8785a40933b83 /lang/perl5.10
parent24577c29d46c4b0bbf4832725530e3110b969961 (diff)
downloadfreebsd-ports-gnome-c7b39a003d5baaa63d5625b4499bd4897c87ff8d.tar.gz
freebsd-ports-gnome-c7b39a003d5baaa63d5625b4499bd4897c87ff8d.tar.zst
freebsd-ports-gnome-c7b39a003d5baaa63d5625b4499bd4897c87ff8d.zip
Fix "pkg_add -r perl" for 5.2-CURRENT (and later). This will now install
perl 5.8 for 5.2-CURRENT. Approved by: perl
Diffstat (limited to 'lang/perl5.10')
-rw-r--r--lang/perl5.10/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index 9a36b92d8cea..8f1fcaa30664 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -24,6 +24,10 @@ PERL_VER= 5.8.2
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+.if ${OSVERSION} < 502100
+LATEST_LINK= perl5.8
+.endif
+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
@@ -206,8 +210,6 @@ MAN3+= GDBM_File.3
.endif
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
-LATEST_LINK= perl5.8
-
test:
@(cd ${WRKSRC}; make test)