aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.12
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-02-02 17:34:05 +0800
committertobez <tobez@FreeBSD.org>2005-02-02 17:34:05 +0800
commit9f11f434fa55a2f2127c22f2c8b210dec4500e26 (patch)
treed1ddd940978ac0b21027d4a923b3ed5d9e727ef1 /lang/perl5.12
parent0589c99541f19a6f3ae7b209e7e0d26e3fc9fbc6 (diff)
downloadfreebsd-ports-gnome-9f11f434fa55a2f2127c22f2c8b210dec4500e26.tar.gz
freebsd-ports-gnome-9f11f434fa55a2f2127c22f2c8b210dec4500e26.tar.zst
freebsd-ports-gnome-9f11f434fa55a2f2127c22f2c8b210dec4500e26.zip
Update bsd.port.mk's notion of the perl version (to 5.8.6) [1].
Use more correct OSVERSION threshold to distinguish between base system perl and perl from ports - the right value is 500036 [1]. Also, simplify OSVERSION-related logic in lang/perl5 and lang/perl5.8. Now it goes as follows: - for lang/perl5.8, if there is perl in the base system, install use.perl script, use a helpful pkg-message, and do not automatically update symlinks; - for lang/perl5.8, if there is no perl in the base system, do not install use.perl script, and update symlinks automatically; - for lang/perl5, always install use.perl; - for lang/perl5, never update symlinks automatically; - for lang/perl5, vary produced pkg-message depending on the presence of the base system perl. Bump PORTREVISION for both lang/perl5 and lang/perl5.8. [1] Approved by: portmgr
Diffstat (limited to 'lang/perl5.12')
-rw-r--r--lang/perl5.12/Makefile6
-rw-r--r--lang/perl5.12/files/use.perl2
2 files changed, 5 insertions, 3 deletions
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index feb908223f83..4b23c9f21a6f 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -90,8 +91,9 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-.if ${OSVERSION} < 502100
LATEST_LINK= perl5.8
+
+.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
.else
PKGMESSAGE= ${PKGDIR}/.not-here
@@ -151,7 +153,7 @@ post-install:
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 502100
+.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
diff --git a/lang/perl5.12/files/use.perl b/lang/perl5.12/files/use.perl
index c20a441b65da..57e1acde0bc8 100644
--- a/lang/perl5.12/files/use.perl
+++ b/lang/perl5.12/files/use.perl
@@ -42,7 +42,7 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 502100 ] ; then
+ if [ $osreldate -ge 500036 ] ; then
need_create_links=yes
need_cleanup_make_conf=yes
need_cleanup_manpath=yes