aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.14/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2002-06-03 05:22:25 +0800
committertobez <tobez@FreeBSD.org>2002-06-03 05:22:25 +0800
commitb88c5d2bd954d603308e154c9e64da3de33fe8c6 (patch)
treeb16469fff36d4c561e4ad96c843122b6cf144ace /lang/perl5.14/Makefile
parentec689584b0e733facb3bd41e4dc0c92fc235bf3d (diff)
downloadfreebsd-ports-gnome-b88c5d2bd954d603308e154c9e64da3de33fe8c6.tar.gz
freebsd-ports-gnome-b88c5d2bd954d603308e154c9e64da3de33fe8c6.tar.zst
freebsd-ports-gnome-b88c5d2bd954d603308e154c9e64da3de33fe8c6.zip
Put SITEARCH and SITELIB paths in front of ARCHLIB and PRIVLIB in the
@INC array. This takes care of the infamous problem of updating the packages already in the perl distribution. With this change, no tricks are any longer necessary for such p5 ports, except the usual tweaking of INSTALLDIRS in Makefile.PL. This last one can also be taken care of by an appropriate BSDPAN modifications, but until we have the `natural' @INC order in the 4.X base system perl, it is meaningless. Do not include iconv.h and do not link with libiconv. Iconv is not used by perl in any way currently, but it used to link it if found. Fix perl on freebsd/sparc64. PR: 33212 (iconv), 37605 (iconv), 38813 (sparc64) Reported by: Vivek Khera <khera@kciLink.com> (iconv), Martin Nilsson <martin@gneto.com> (iconv) Submitted by: jake (sparc64)
Diffstat (limited to 'lang/perl5.14/Makefile')
-rw-r--r--lang/perl5.14/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 0f3421da7c36..45c41b773286 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/}
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Dman3dir=${PREFIX}/lib/perl5/${PERL_VER}/man/man3 \
-Dsitearch=${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH} \
-Dsitelib=${PREFIX}/lib/perl5/site_perl/${PERL_VER} \
- -Ui_gdbm -Ui_malloc -Dccflags=-DAPPLLIB_EXP=\"${BSDPAN_DEST}\"
+ -Ui_gdbm -Ui_malloc -Ui_iconv -Dccflags=-DAPPLLIB_EXP=\"${BSDPAN_DEST}\"
INSTALLS_SHLIB= yes
INCLUDEDIR= /usr/include