aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.14/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-04-01 20:29:12 +0800
committersobomax <sobomax@FreeBSD.org>2003-04-01 20:29:12 +0800
commit9d06242607edf8173caafcfd6745f246c0100640 (patch)
tree353d36041db219f9c79130d26f683d2081d9bbd2 /lang/perl5.14/Makefile
parent0fc402e3c1c990aaaddafbfb2d00a83a13d4cd01 (diff)
downloadfreebsd-ports-gnome-9d06242607edf8173caafcfd6745f246c0100640.tar.gz
freebsd-ports-gnome-9d06242607edf8173caafcfd6745f246c0100640.tar.zst
freebsd-ports-gnome-9d06242607edf8173caafcfd6745f246c0100640.zip
Add a new `WITH_THREADS' option to build perl with support for threads and
fix threaded build on 5.x. Approved by: maintainer
Diffstat (limited to 'lang/perl5.14/Makefile')
-rw-r--r--lang/perl5.14/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index ec6a3d6cd0bc..d2c14bf05ddd 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
CONFIGURE_ARGS+= -Dusemymalloc=n
.endif
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= -Dusethreads=y
+PKGNAMESUFFIX= -threaded
+.else
+CONFIGURE_ARGS+= -Dusethreads=n
+.endif
+
INCLUDEDIR= /usr/include
.include <bsd.port.pre.mk>