aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.14
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-08-08 22:32:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-08-08 22:32:41 +0800
commit34d55e6b41191c613744cadd7667bd3bd5a73866 (patch)
tree967a31623887de204f8dd1395f0cff830686b455 /lang/perl5.14
parent044449aeb3a93c42d5830a0b1a26325e7b3ab35b (diff)
downloadfreebsd-ports-gnome-34d55e6b41191c613744cadd7667bd3bd5a73866.tar.gz
freebsd-ports-gnome-34d55e6b41191c613744cadd7667bd3bd5a73866.tar.zst
freebsd-ports-gnome-34d55e6b41191c613744cadd7667bd3bd5a73866.zip
- Fix perl configure erroneously saving /usr/local/script as a site script install directory if it's present, which leads to misinstallation of many ports which install perl scripts (p5-Mail-SpamAssassin, for example)
PR: 149771 Submitted by: Peter Radcliffe <pir-freebsd.org@pir.net> Patch by: myself Approved by: jadawin
Diffstat (limited to 'lang/perl5.14')
-rw-r--r--lang/perl5.14/Makefile1
-rw-r--r--lang/perl5.14/files/patch-Configure12
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 65e2f17fa089..b847383570e0 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
diff --git a/lang/perl5.14/files/patch-Configure b/lang/perl5.14/files/patch-Configure
index 0abb559cbc33..21ccd2c8c62e 100644
--- a/lang/perl5.14/files/patch-Configure
+++ b/lang/perl5.14/files/patch-Configure
@@ -1,6 +1,6 @@
--- Configure.orig 2010-07-14 15:28:45.000000000 +0000
+++ Configure 2010-07-14 15:29:23.000000000 +0000
-@@ -4780,7 +4780,7 @@
+@@ -4798,7 +4798,7 @@
libpth=''
for xxx in $dlist
do
@@ -9,3 +9,13 @@
case " $libpth " in
*" $xxx "*) ;;
*) libpth="$libpth $xxx";;
+@@ -9125,8 +9125,7 @@
+
+ : determine where add-on public executable scripts go
+ case "$sitescript" in
+-'') dflt=$siteprefix/script
+- $test -d $dflt || dflt=$sitebin ;;
++'') dflt=$sitebin ;;
+ *) dflt="$sitescript" ;;
+ esac
+ fn=d~+