aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.14
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-02-14 18:17:07 +0800
committertobez <tobez@FreeBSD.org>2005-02-14 18:17:07 +0800
commit4a258b68f64d7c4042554396af2b5bb1bf6a5c56 (patch)
treeafa9c3b8c5290aaf71dc7da19ec1506fbe888e8e /lang/perl5.14
parent782c3bd54ad443a1fd09c29ca91f9fc7a2bee6d2 (diff)
downloadfreebsd-ports-gnome-4a258b68f64d7c4042554396af2b5bb1bf6a5c56.tar.gz
freebsd-ports-gnome-4a258b68f64d7c4042554396af2b5bb1bf6a5c56.tar.zst
freebsd-ports-gnome-4a258b68f64d7c4042554396af2b5bb1bf6a5c56.zip
If one of locale-related variables set to a bad value in the user's
environment (like da_DK.ISO_8859-15 as opposed to da_DK.ISO8859-15 on -CURRENT), perl ports cannot be built. While this condition clearly is an operator error, it is still no excuse for the build failure. Fix that by cleaning locale-related variables for configure and build steps. No plist changes, no portrevision bump. Reported by: Flemming Jacobsen <fj quite-at batmule maybe-dot dk>
Diffstat (limited to 'lang/perl5.14')
-rw-r--r--lang/perl5.14/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index ba5fd45a0754..f349ce63a9e9 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -39,6 +39,11 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Ui_malloc -Ui_iconv -Uinstallusrbinperl \
-Dcc="${CC}" -Doptimize="${CFLAGS}" -Duseshrplib \
-Dccflags=-DAPPLLIB_EXP=\"${BSDPAN_DEST}\"
+LOCALE_CLEANUP= LANG="" LC_ALL="" LC_COLLATE="" LC_CTYPE="" \
+ LC_MESSAGES="" LC_MONETARY="" LC_NUMERIC="" \
+ LC_TIME=""
+CONFIGURE_ENV+= ${LOCALE_CLEANUP}
+MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>