aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.14
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2002-07-28 17:14:17 +0800
committertobez <tobez@FreeBSD.org>2002-07-28 17:14:17 +0800
commitf789e21ed1e8307c53904765ce53abe9d2cb0ab8 (patch)
tree4ddec11578599ec11b16c3f26cff7f41cce3032e /lang/perl5.14
parent311c07b607af05e0719c373ce72af84e5d6f1715 (diff)
downloadfreebsd-ports-gnome-f789e21ed1e8307c53904765ce53abe9d2cb0ab8.tar.gz
freebsd-ports-gnome-f789e21ed1e8307c53904765ce53abe9d2cb0ab8.tar.zst
freebsd-ports-gnome-f789e21ed1e8307c53904765ce53abe9d2cb0ab8.zip
Merge from lang/perl5:
Add two knobs: WITH_PERL_MALLOC - to compile with perl's own malloc, as opposed to the freebsd system malloc. Some might find this useful, since perl's malloc is marginally faster in typical cases, and orders of magnitude faster in degenerate cases. Use with care. WITH_GDBM - to compile with gdbm support.
Diffstat (limited to 'lang/perl5.14')
-rw-r--r--lang/perl5.14/Makefile23
-rw-r--r--lang/perl5.14/pkg-plist4
2 files changed, 24 insertions, 3 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 1570660ed19f..d2c263853678 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -31,11 +31,25 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Dman3dir=${PREFIX}/lib/perl5/${PERL_VER}/man/man3 \
-Dsitearch=${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH} \
-Dsitelib=${PREFIX}/lib/perl5/site_perl/${PERL_VER} \
- -Ui_gdbm -Ui_malloc -Ui_iconv \
- -Uinstallusrbinperl \
+ -Ui_malloc -Ui_iconv -Uinstallusrbinperl \
-Dccflags=-DAPPLLIB_EXP=\"${BSDPAN_DEST}\"
# INSTALLS_SHLIB= yes
+.if defined(WITH_GDBM)
+CONFIGURE_ARGS+= -Di_gdbm
+LIB_DEPENDS+= gdbm.2:${PORTSDIR}/databases/gdbm
+PLIST_SUB+= GDBM=""
+.else
+CONFIGURE_ARGS+= -Ui_gdbm
+PLIST_SUB+= GDBM="@comment "
+.endif
+
+.if defined(WITH_PERL_MALLOC)
+CONFIGURE_ARGS+= -Dusemymalloc=y
+.else
+CONFIGURE_ARGS+= -Dusemymalloc=n
+.endif
+
INCLUDEDIR= /usr/include
.include <bsd.port.pre.mk>
@@ -153,6 +167,9 @@ MAN3= AnyDBM_File.3 Attribute::Handlers.3 \
open.3 ops.3 overload.3 re.3 sigtrap.3 sort.3 strict.3 \
subs.3 threads.3 threads::shared.3 utf8.3 vars.3 vmsish.3 \
warnings.3 warnings::register.3
+.if defined(WITH_GDBM)
+MAN3+= GDBM_File.3
+.endif
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
LATEST_LINK= perl5.8
diff --git a/lang/perl5.14/pkg-plist b/lang/perl5.14/pkg-plist
index e024ffbe6af6..2790feac56e6 100644
--- a/lang/perl5.14/pkg-plist
+++ b/lang/perl5.14/pkg-plist
@@ -334,6 +334,8 @@ lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Glob/Glob.so
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Glob/Glob.bs
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/Fcntl/Fcntl.so
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/Fcntl/Fcntl.bs
+%%GDBM%%lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/GDBM_File.so
+%%GDBM%%lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/GDBM_File.bs
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/Encode/Encode.so
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/Encode/Encode.bs
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/Encode/Unicode/Unicode.so
@@ -390,6 +392,7 @@ lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/IPC/SysV.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/I18N/Langinfo.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Filter/Util/Call.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/File/Glob.pm
+%%GDBM%%lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/GDBM_File.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Devel/DProf.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Devel/PPPort.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Devel/Peek.pm
@@ -1285,6 +1288,7 @@ lib/perl5/%%PERL_VER%%/AutoSplit.pm
@unexec find %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/ -name '*.ph' -delete 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%% 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl 2>/dev/null || true
+%%GDBM%%@dirrm lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File
@unexec rmdir %D/lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/threads 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/XS 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Sys 2>/dev/null || true