aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.16/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2003-11-12 08:07:43 +0800
committertobez <tobez@FreeBSD.org>2003-11-12 08:07:43 +0800
commitc758710d2ccd569eded8c36de7d730b3aac2e987 (patch)
tree705d8a7d588d1054d693d6a65ddd9c0cd221cbcc /lang/perl5.16/Makefile
parent1b07d7aee1c34ed7f76dacd9fcf663a69046eeed (diff)
downloadfreebsd-ports-gnome-c758710d2ccd569eded8c36de7d730b3aac2e987.tar.gz
freebsd-ports-gnome-c758710d2ccd569eded8c36de7d730b3aac2e987.tar.zst
freebsd-ports-gnome-c758710d2ccd569eded8c36de7d730b3aac2e987.zip
In some cases of weird symlinking (possibly triggered by portupgrade),
perl binary might fail to be installed during make install. Try to fix that. Reported by: "Shobaki sam." <shsam@free.fr> PR: 59186
Diffstat (limited to 'lang/perl5.16/Makefile')
-rw-r--r--lang/perl5.16/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index a5dcb773d0c5..7fe073530167 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -219,10 +220,14 @@ post-patch:
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
+pre-install:
+ @${RM} -f ${PREFIX}/bin/perl${PERL_VER}
+ @${RM} -f ${PREFIX}/bin/perl
+
post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/perl${PERL_VER}
@${STRIP_CMD} ${PREFIX}/bin/perl
- @${LN} -sf ${PREFIX}/bin/perl ${PREFIX}/bin/perl5
- @${LN} -sf ${PREFIX}/bin/perl ${PREFIX}/bin/perl${PERL_VER}
+ @${LN} -sf ${PREFIX}/bin/perl${PERL_VER} ${PREFIX}/bin/perl5
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
.for files in ${BSDPAN_FILES}
${MKDIR} ${BSDPAN_DEST}/${files:H}