aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.16
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
committerasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
commit559e1bc28bd975c38b561de15be3918ba1f71b5e (patch)
treecda169bf1e41b7166c2d2febd3d858c1411d0e64 /lang/perl5.16
parent7aed28166a84f266be861367fc9a1add43f9219a (diff)
downloadfreebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.gz
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.zst
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Diffstat (limited to 'lang/perl5.16')
-rw-r--r--lang/perl5.16/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index ff11ae222c62..8ecf159155dc 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -3,7 +3,7 @@
# Date created: 16 April 1995
# Whom: markm
#
-# $Id: Makefile,v 1.25 1998/08/15 16:33:13 markm Exp $
+# $Id: Makefile,v 1.26 1998/10/12 06:51:07 markm Exp $
#
DISTNAME= perl5.005_02
@@ -18,8 +18,9 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -sde -Dprefix=${PREFIX}
-OSVER!= sysctl -n kern.osreldate
-.if ${OSVER} > 300003
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 300003
BROKEN= perl is in system
.endif
@@ -87,4 +88,4 @@ post-install:
@ln -sf ${PREFIX}/bin/perl ${PREFIX}/bin/perl5
@(cd /usr/include && ${PREFIX}/bin/h2ph *.h machine/*.h sys/*.h)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>