aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.20/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-09 20:21:29 +0800
committermat <mat@FreeBSD.org>2015-04-09 20:21:29 +0800
commitcf2a77e0ba5ea7db025e4e9c299c05cac24efbd5 (patch)
tree13588e47865d92c5a884f61a462b25fb3c56bb9f /lang/perl5.20/Makefile
parent6e8d0466ac640db21041c593adbb8c65a7ce3940 (diff)
downloadfreebsd-ports-gnome-cf2a77e0ba5ea7db025e4e9c299c05cac24efbd5.tar.gz
freebsd-ports-gnome-cf2a77e0ba5ea7db025e4e9c299c05cac24efbd5.tar.zst
freebsd-ports-gnome-cf2a77e0ba5ea7db025e4e9c299c05cac24efbd5.zip
Make Perl build more reproducibly.
Differential Revision: https://reviews.freebsd.org/D2016 Some bits from: Jérémy Bobbio <lunar@debian.org> Sponsored by: Absolight
Diffstat (limited to 'lang/perl5.20/Makefile')
-rw-r--r--lang/perl5.20/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/perl5.20/Makefile b/lang/perl5.20/Makefile
index 451fbcea31c9..d0ad5aac51d1 100644
--- a/lang/perl5.20/Makefile
+++ b/lang/perl5.20/Makefile
@@ -3,6 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../src
@@ -83,7 +84,9 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Dsiteman3dir=${SITE_MAN3} \
-Dsiteman1dir=${PREFIX}/man/man1 \
-Ui_malloc -Ui_iconv -Uinstallusrbinperl -Dusenm=n \
- -Dcc="${CC}" -Duseshrplib -Dinc_version_list=none
+ -Dcc="${CC}" -Duseshrplib -Dinc_version_list=none \
+ -Dcf_by=${MAINTAINER:C,@.*,,} -Dcf_email=${MAINTAINER} \
+ -Dcf_time="`env LANG=C ${STAT} -t \"%a %b %d %T %Z %Y\" -f %Sm ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX}`"
# Keep the following two in sync.
# lddlflags is used for all .so linking
# shrpldflags is used for libperl.so, so remove all the extra bits inherited from lddlflags.