aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.20
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-11 19:29:31 +0800
committermat <mat@FreeBSD.org>2016-04-11 19:29:31 +0800
commitad897e3ae68cb83143d2a8bf778bfb3ccfe87672 (patch)
treedb7bb018b870dd17e2447ea67579eb8dd2bfd1ea /lang/perl5.20
parent81dad851b22b0359940be78606acab3278c3efd2 (diff)
downloadfreebsd-ports-gnome-ad897e3ae68cb83143d2a8bf778bfb3ccfe87672.tar.gz
freebsd-ports-gnome-ad897e3ae68cb83143d2a8bf778bfb3ccfe87672.tar.zst
freebsd-ports-gnome-ad897e3ae68cb83143d2a8bf778bfb3ccfe87672.zip
Patch Config_heavy.pl so that -L${WRKSRC} is not removed after Perl is built.
Sponsored by: Absolight
Diffstat (limited to 'lang/perl5.20')
-rw-r--r--lang/perl5.20/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/perl5.20/Makefile b/lang/perl5.20/Makefile
index 7aaa36c41bdb..a8610e63b80e 100644
--- a/lang/perl5.20/Makefile
+++ b/lang/perl5.20/Makefile
@@ -3,7 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN/../../src/5.0
DIST_SUBDIR= perl
@@ -233,10 +233,15 @@ post-patch-PTHREAD-off:
${WRKSRC}/hints/freebsd.sh
.endif
-.if ${CC} == /nxb-bin/usr/bin/cc
post-build:
+ @${REINPLACE_CMD} -e '/^lddlflags/s|-L${WRKSRC} ||' \
+ ${WRKSRC}/lib/Config_heavy.pl
+.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${WRKSRC}/lib/Config.pm ${WRKSRC}/lib/Config_heavy.pl
+# Restore Config.pm's timestamp so that Perl's build system does not think it
+# needs to rebuild everything.
+ @${TOUCH} -r ${WRKSRC}/lib/Config.pm.bak ${WRKSRC}/lib/Config.pm
.endif
post-install: