aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.8
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-04-01 20:29:12 +0800
committersobomax <sobomax@FreeBSD.org>2003-04-01 20:29:12 +0800
commit9d06242607edf8173caafcfd6745f246c0100640 (patch)
tree353d36041db219f9c79130d26f683d2081d9bbd2 /lang/perl5.8
parent0fc402e3c1c990aaaddafbfb2d00a83a13d4cd01 (diff)
downloadfreebsd-ports-gnome-9d06242607edf8173caafcfd6745f246c0100640.tar.gz
freebsd-ports-gnome-9d06242607edf8173caafcfd6745f246c0100640.tar.zst
freebsd-ports-gnome-9d06242607edf8173caafcfd6745f246c0100640.zip
Add a new `WITH_THREADS' option to build perl with support for threads and
fix threaded build on 5.x. Approved by: maintainer
Diffstat (limited to 'lang/perl5.8')
-rw-r--r--lang/perl5.8/Makefile7
-rw-r--r--lang/perl5.8/files/patch-ac15
2 files changed, 20 insertions, 2 deletions
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index ec6a3d6cd0bc..d2c14bf05ddd 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
CONFIGURE_ARGS+= -Dusemymalloc=n
.endif
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= -Dusethreads=y
+PKGNAMESUFFIX= -threaded
+.else
+CONFIGURE_ARGS+= -Dusethreads=n
+.endif
+
INCLUDEDIR= /usr/include
.include <bsd.port.pre.mk>
diff --git a/lang/perl5.8/files/patch-ac b/lang/perl5.8/files/patch-ac
index 313b7d4b48f2..f7255c5d354c 100644
--- a/lang/perl5.8/files/patch-ac
+++ b/lang/perl5.8/files/patch-ac
@@ -1,7 +1,8 @@
+
$FreeBSD$
---- hints/freebsd.sh.orig Sat Jun 1 19:03:12 2002
-+++ hints/freebsd.sh Sat Jul 20 22:51:05 2002
+--- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
++++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
@@ -98,6 +98,13 @@
;;
esac
@@ -25,3 +26,13 @@ $FreeBSD$
;;
esac
+@@ -223,6 +230,9 @@
+ 4.*) # 4.x has gethostbyaddr_r but it is
+ # "Temporary function, not threadsafe"...
+ d_gethostbyaddr_r="undef"
++ d_gethostbyaddr_r_proto="undef"
++ ;;
++ 5.*) d_gethostbyaddr_r="undef"
+ d_gethostbyaddr_r_proto="undef"
+ ;;
+ esac