aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.8
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2009-06-08 22:35:28 +0800
committerskv <skv@FreeBSD.org>2009-06-08 22:35:28 +0800
commit8ad966f7206f08f6cd79e16802c8f11692f69cd2 (patch)
treeeb7aa6065aae70cedbb950a37cc7c3b863a83102 /lang/perl5.8
parent2c15c09769625187177917f0d434c68ab7b734d2 (diff)
downloadfreebsd-ports-gnome-8ad966f7206f08f6cd79e16802c8f11692f69cd2.tar.gz
freebsd-ports-gnome-8ad966f7206f08f6cd79e16802c8f11692f69cd2.tar.zst
freebsd-ports-gnome-8ad966f7206f08f6cd79e16802c8f11692f69cd2.zip
- Add more essential bugfixes
- Add perl-threaded-5.* to CONFLICTS [1] - Introduce PERL_VENDOR_PREFIX variable - Be really PREFIX-neutral [2} Submitted by: lth [1], rafan [2]
Diffstat (limited to 'lang/perl5.8')
-rw-r--r--lang/perl5.8/Makefile16
-rw-r--r--lang/perl5.8/files/patch-bug6456224
2 files changed, 38 insertions, 2 deletions
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index 82de43424c68..5b74e6c94ce5 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -25,7 +25,7 @@ PATCHFILES= defined-or-${PERL_VERSION}.bz2
MAINTAINER= skv@FreeBSD.org
COMMENT= Practical Extraction and Report Language
-CONFLICTS= perl-5.6.* perl-5.10.*
+CONFLICTS= perl-5.6.* perl-5.10.* perl-threaded-5.10.*
OPTIONS= DEBUGGING "Build with debugging support" off \
GDBM "Build GDBM_File extension" off \
@@ -66,6 +66,16 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+.if defined(PERL_VENDOR_PREFIX)
+CONFIGURE_ARGS+= \
+ -Dvendorprefix=${PERL_VENDOR_PREFIX} \
+ -Dvendorarch=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/${PERL_ARCH} \
+ -Dvendorbin=${PERL_VENDOR_PREFIX}/bin \
+ -Dvendorlib=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION} \
+ -Dvendorman3dir=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/man/man3 \
+ -Dvendorman1dir=${PERL_VENDOR_PREFIX}/man/man1
+.endif
+
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PERL_VER=${PERL_VERSION} \
PERL_ARCH=${PERL_ARCH} \
@@ -162,6 +172,8 @@ post-patch:
${CP} ${WRKDIR}/use.perl ${PKGDEINSTALL}
${SED} -i '' -e 's|%%PERL_PKGNAME%%|${PKGNAME}|g; s|%%PERL_VER%%|5.8|g;' \
${BSDPAN_WRKSRC}/ExtUtils/*.pm
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
.if defined(WITH_THREADS)
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
diff --git a/lang/perl5.8/files/patch-bug64562 b/lang/perl5.8/files/patch-bug64562
new file mode 100644
index 000000000000..d3291d07d243
--- /dev/null
+++ b/lang/perl5.8/files/patch-bug64562
@@ -0,0 +1,24 @@
+# http://rt.perl.org/rt3/Public/Bug/Display.html?id=64562
+# Adapted from:
+# http://perl5.git.perl.org/perl.git/commitdiff/ee6d2783b2d78accfac54397826acf5f6e1715e1?hp=5a8cf367090fb5d83d8e8e0ae381a3525a215928
+diff --git a/op.c b/op.c
+index 517f648..89ed522 100644
+--- op.c
++++ op.c
+@@ -6166,9 +6166,13 @@ Perl_newFORM(pTHX_ I32 floor, OP *o, OP *block)
+ const line_t oldline = CopLINE(PL_curcop);
+ if (PL_copline != NOLINE)
+ CopLINE_set(PL_curcop, PL_copline);
+- Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
+- o ? "Format %"SVf" redefined"
+- : "Format STDOUT redefined", (void*)cSVOPo->op_sv);
++ if (o) {
++ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
++ "Format %"SVf" redefined", (void*)cSVOPo->op_sv);
++ } else {
++ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
++ "Format STDOUT redefined");
++ }
+ CopLINE_set(PL_curcop, oldline);
+ }
+ SvREFCNT_dec(cv);