aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2002-07-28 16:25:07 +0800
committertobez <tobez@FreeBSD.org>2002-07-28 16:25:07 +0800
commit311c07b607af05e0719c373ce72af84e5d6f1715 (patch)
tree1d6221c1985a7b0261cbc816fb4cf20a89af2c50 /lang/perl5
parentc8b3a4f5575caa21e1623bbf9d8713a8f20b970f (diff)
downloadfreebsd-ports-gnome-311c07b607af05e0719c373ce72af84e5d6f1715.tar.gz
freebsd-ports-gnome-311c07b607af05e0719c373ce72af84e5d6f1715.tar.zst
freebsd-ports-gnome-311c07b607af05e0719c373ce72af84e5d6f1715.zip
Add two knobs:
WITH_PERL_MALLOC - to compile with perl's own malloc, as opposed to the freebsd system malloc. Some might find this useful, since perl's malloc is marginally faster in typical cases, and orders of magnitude faster in degenerate cases. Use with care. WITH_GDBM - to compile with gdbm support. Requested by: netchild (WITH_PERL_MALLOC), Joachim Leidinger <jojo@blackpoint.de> (WITH_GDBM)
Diffstat (limited to 'lang/perl5')
-rw-r--r--lang/perl5/Makefile22
-rw-r--r--lang/perl5/files/patch-ac14
-rw-r--r--lang/perl5/pkg-plist5
3 files changed, 34 insertions, 7 deletions
diff --git a/lang/perl5/Makefile b/lang/perl5/Makefile
index 064357a973e6..943341d19ed3 100644
--- a/lang/perl5/Makefile
+++ b/lang/perl5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/}
@@ -30,9 +30,24 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Dman3dir=${PREFIX}/lib/perl5/${PERL_VER}/man/man3 \
-Dsitearch=${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH} \
-Dsitelib=${PREFIX}/lib/perl5/site_perl/${PERL_VER} \
- -Ui_gdbm -Ui_malloc -Ui_iconv -Dccflags=-DAPPLLIB_EXP=\"${BSDPAN_DEST}\"
+ -Ui_malloc -Ui_iconv -Dccflags=-DAPPLLIB_EXP=\"${BSDPAN_DEST}\"
INSTALLS_SHLIB= yes
+.if defined(WITH_GDBM)
+CONFIGURE_ARGS+= -Di_gdbm
+LIB_DEPENDS+= gdbm.2:${PORTSDIR}/databases/gdbm
+PLIST_SUB+= GDBM=""
+.else
+CONFIGURE_ARGS+= -Ui_gdbm
+PLIST_SUB+= GDBM="@comment "
+.endif
+
+.if defined(WITH_PERL_MALLOC)
+CONFIGURE_ARGS+= -Dusemymalloc=y
+.else
+CONFIGURE_ARGS+= -Dusemymalloc=n
+.endif
+
INCLUDEDIR= /usr/include
.include <bsd.port.pre.mk>
@@ -108,6 +123,9 @@ MAN3= AnyDBM_File.3 AutoLoader.3 AutoSplit.3 B.3 B::Asmdata.3 \
diagnostics.3 fields.3 filetest.3 integer.3 less.3 lib.3 \
locale.3 open.3 ops.3 overload.3 re.3 sigtrap.3 strict.3 \
subs.3 utf8.3 vars.3 warnings.3 warnings::register.3
+.if defined(WITH_GDBM)
+MAN3+= GDBM_File.3
+.endif
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
diff --git a/lang/perl5/files/patch-ac b/lang/perl5/files/patch-ac
index c9cfeb9ba5a0..41b4b73fb67a 100644
--- a/lang/perl5/files/patch-ac
+++ b/lang/perl5/files/patch-ac
@@ -1,15 +1,19 @@
$FreeBSD$
---- hints/freebsd.sh.orig Sun Apr 8 06:09:16 2001
-+++ hints/freebsd.sh Sat Jun 1 23:41:18 2002
-@@ -85,10 +85,17 @@
+--- hints/freebsd.sh.orig Sun Jul 28 09:37:51 2002
++++ hints/freebsd.sh Sun Jul 28 09:39:23 2002
+@@ -85,10 +85,20 @@
d_setreuid='define'
d_setegid='undef'
d_seteuid='undef'
+ d_dosuid='define'
;;
*) usevfork='true'
- usemymalloc='n'
+- usemymalloc='n'
++ case "$usemymalloc" in
++ "") usemymalloc='n'
++ ;;
++ esac
libswanted=`echo $libswanted | sed 's/ malloc / /'`
+ libswanted=`echo $libswanted | sed 's/ bind / /'`
+ d_setregid='define'
@@ -20,7 +24,7 @@ $FreeBSD$
;;
esac
-@@ -115,7 +121,8 @@
+@@ -115,7 +125,8 @@
fi
lddlflags='-Bshareable'
fi
diff --git a/lang/perl5/pkg-plist b/lang/perl5/pkg-plist
index a20d2fd04ad6..724f5b63d144 100644
--- a/lang/perl5/pkg-plist
+++ b/lang/perl5/pkg-plist
@@ -288,6 +288,7 @@ lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/DynaLoader.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Errno.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Fcntl.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/File/Glob.pm
+%%GDBM%%lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/GDBM_File.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/IO.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/IO/Dir.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/IO/File.pm
@@ -336,6 +337,9 @@ lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/Fcntl/Fcntl.so
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Glob/Glob.bs
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Glob/Glob.so
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Glob/autosplit.ix
+%%GDBM%%lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/autosplit.ix
+%%GDBM%%lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/GDBM_File.so
+%%GDBM%%lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File/GDBM_File.bs
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/IO.bs
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/IO.so
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/SysV/SysV.bs
@@ -899,6 +903,7 @@ lib/perl5/%%PERL_VER%%/warnings/register.pm
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/machine 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%% 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/5.6.1 2>/dev/null || true
+%%GDBM%%@dirrm lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/auto/GDBM_File
@unexec rmdir %D/lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Sys 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/IO 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/Data 2>/dev/null || true