aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pgcc
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
committerasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
commit04f6beab8f8083412efad3eadf4e32bffa85bbe2 (patch)
tree907e6a967f7d00919c4dc13b6a581739f386e7ef /lang/pgcc
parent755e63021c52f5292b5284c5d10c05274df15811 (diff)
downloadfreebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.gz
freebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.zst
freebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.zip
Fix to make ports work with bsd.port.mk rev. 1.306.
${MACHINE_ARCH}--freebsd${OSREL} is now passed to CONFIGURE_ARGS if GNU_CONFIGURE is defined. Take the target out of CONFIGURE_ARGS of some ports that added it explicitly; define it as ${MACHINE_ARCH}--freebsd if the port doesn't like the ${OSREL} part; define it as something else (such as ${MACHINE_ARCH}--freebsdelf if the port requires that; define it as an empty string if the port doesn't like it at all. The last might be a sign that a GNU_CONFIGURE port actually doesn't use GNU's version of configure at all; but I don't have time to go look at them all, we'll fix them as time goes on. At least we've got much fewer "-unknown-"s in the tree as the result. :)
Diffstat (limited to 'lang/pgcc')
-rw-r--r--lang/pgcc/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/pgcc/Makefile b/lang/pgcc/Makefile
index 811f850d85e6..7afcc459632b 100644
--- a/lang/pgcc/Makefile
+++ b/lang/pgcc/Makefile
@@ -4,7 +4,7 @@
# Date created: 10 Dec 1998
# Whom: David O'Brien <obrien@NUXI.com>
#
-# $Id: Makefile,v 1.13 1998/12/14 12:07:48 obrien Exp $
+# $Id: Makefile,v 1.14 1999/02/03 11:11:52 asami Exp $
#
DISTNAME= egcs-1.1.1
@@ -46,8 +46,9 @@ PATCH_DIST_STRIP?= -p1
PLIST_SUB= EGCS_REV=${EGCS_REV} GNU_HOST=${GNUHOST}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --with-gnu-as --with-gnu-ld ${GNUHOST} \
+CONFIGURE_ARGS= --with-gnu-as --with-gnu-ld \
--with-gxx-include-dir=${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/include/g++
+CONFIGURE_TARGET= ${GNUHOST}
ALL_TARGET= bootstrap
MAN1= cccp.1 g++.1 g77.1 gcc.1