aboutsummaryrefslogtreecommitdiffstats
path: root/lang/phantomjs
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-10-01 14:35:50 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-10-01 14:35:50 +0800
commitb325c1870b46dec84b1d12b807c59413538477da (patch)
tree2d2f95ae9a0a04ee003f332f93ab5426bb891133 /lang/phantomjs
parent208da747c9d6c364c5157322801ba5430dcf74f1 (diff)
downloadfreebsd-ports-gnome-b325c1870b46dec84b1d12b807c59413538477da.tar.gz
freebsd-ports-gnome-b325c1870b46dec84b1d12b807c59413538477da.tar.zst
freebsd-ports-gnome-b325c1870b46dec84b1d12b807c59413538477da.zip
- Convert sparc64 BROKEN to helper
- Mark BROKEN on 9.0 i386: In file included from /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/include/QtCore/qglobal.h:1, from /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/qmake/library/qmake_global.h:45, from /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/qmake/library/qmakeparser.h:45, from /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/qmake/library/qmakeevaluator.h:49, from /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/qmake/project.h:45, from /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/qmake/project.cpp:42: /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/include/QtCore/../../src/corelib/global/qglobal.h:443: error: 'QT_POINTER_SIZE' was not declared in this scope /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/include/QtCore/../../src/corelib/global/qglobal.h:443: error: template argument 1 is invalid /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/include/QtCore/../../src/corelib/global/qglobal.h:443: error: expected initializer before 'qregisterint' /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/include/QtCore/../../src/corelib/global/qglobal.h:444: error: 'QT_POINTER_SIZE' was not declared in this scope /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/include/QtCore/../../src/corelib/global/qglobal.h:444: error: template argument 1 is invalid /wrkdirs/usr/ports/lang/phantomjs/work/phantomjs-2.0.0/src/qt/qtbase/include/QtCore/../../src/corelib/global/qglobal.h:444: error: expected initializer before 'qregisteruint' Reported by: pkg-fallout Obtained from: portmgr blanket
Diffstat (limited to 'lang/phantomjs')
-rw-r--r--lang/phantomjs/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index e86707dd13f8..d86f7a97974a 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -19,6 +19,9 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libicui18n.so:devel/icu \
libpng.so:graphics/png
+BROKEN_sparc64= does not link on sparc64
+BROKEN_FreeBSD_9_i386= does not build
+
PROJECTHOST= phantomjs
USES= bison:build compiler:c++11-lang gmake gperf jpeg perl5 pkgconfig python:build zip
USE_PERL5= build
@@ -54,10 +57,4 @@ do-build:
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} bin/phantomjs ${STAGEDIR}${PREFIX}/bin/
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not link on sparc64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>