aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php-mode.el/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2002-06-22 04:06:20 +0800
committerdemon <demon@FreeBSD.org>2002-06-22 04:06:20 +0800
commite949b3fe2954f33d4bd9c9217a09ac59b012eaca (patch)
tree08c6ef47020805151d6396d4856b4caebb4d839c /lang/php-mode.el/Makefile
parente4e4274a7450f3c09fa83a2f1ea68323b57c8b04 (diff)
downloadfreebsd-ports-gnome-e949b3fe2954f33d4bd9c9217a09ac59b012eaca.tar.gz
freebsd-ports-gnome-e949b3fe2954f33d4bd9c9217a09ac59b012eaca.tar.zst
freebsd-ports-gnome-e949b3fe2954f33d4bd9c9217a09ac59b012eaca.zip
New port: Emacs major mode for editing PHP files.
Diffstat (limited to 'lang/php-mode.el/Makefile')
-rw-r--r--lang/php-mode.el/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/lang/php-mode.el/Makefile b/lang/php-mode.el/Makefile
new file mode 100644
index 000000000000..56a4d68381b8
--- /dev/null
+++ b/lang/php-mode.el/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: php-mode.el
+# Date created: 21 June 2002
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= php-mode.el
+PORTVERSION= 1.0.2
+CATEGORIES= lang elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=php-mode
+DISTNAME= php-mode-102.el
+EXTRACT_SUFX= #empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= ports@FreeBSD.org
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+do-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${EMACSLISPDIR}/php-mode.el
+ ${LN} -sf ${EMACSLISPDIR}/php-mode.el ${XEMACSLISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>