aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php-mode.el
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2002-06-22 04:06:20 +0800
committerdemon <demon@FreeBSD.org>2002-06-22 04:06:20 +0800
commite949b3fe2954f33d4bd9c9217a09ac59b012eaca (patch)
tree08c6ef47020805151d6396d4856b4caebb4d839c /lang/php-mode.el
parente4e4274a7450f3c09fa83a2f1ea68323b57c8b04 (diff)
downloadfreebsd-ports-gnome-e949b3fe2954f33d4bd9c9217a09ac59b012eaca.tar.gz
freebsd-ports-gnome-e949b3fe2954f33d4bd9c9217a09ac59b012eaca.tar.zst
freebsd-ports-gnome-e949b3fe2954f33d4bd9c9217a09ac59b012eaca.zip
New port: Emacs major mode for editing PHP files.
Diffstat (limited to 'lang/php-mode.el')
-rw-r--r--lang/php-mode.el/Makefile34
-rw-r--r--lang/php-mode.el/distinfo1
-rw-r--r--lang/php-mode.el/pkg-comment1
-rw-r--r--lang/php-mode.el/pkg-descr3
-rw-r--r--lang/php-mode.el/pkg-message4
-rw-r--r--lang/php-mode.el/pkg-plist6
6 files changed, 49 insertions, 0 deletions
diff --git a/lang/php-mode.el/Makefile b/lang/php-mode.el/Makefile
new file mode 100644
index 000000000000..56a4d68381b8
--- /dev/null
+++ b/lang/php-mode.el/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: php-mode.el
+# Date created: 21 June 2002
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= php-mode.el
+PORTVERSION= 1.0.2
+CATEGORIES= lang elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=php-mode
+DISTNAME= php-mode-102.el
+EXTRACT_SUFX= #empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= ports@FreeBSD.org
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+do-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${EMACSLISPDIR}/php-mode.el
+ ${LN} -sf ${EMACSLISPDIR}/php-mode.el ${XEMACSLISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/lang/php-mode.el/distinfo b/lang/php-mode.el/distinfo
new file mode 100644
index 000000000000..c55043dcb5e2
--- /dev/null
+++ b/lang/php-mode.el/distinfo
@@ -0,0 +1 @@
+MD5 (php-mode-102.el) = bbf006aec2f76f8bb609d4314df3a065
diff --git a/lang/php-mode.el/pkg-comment b/lang/php-mode.el/pkg-comment
new file mode 100644
index 000000000000..031a67dd1d67
--- /dev/null
+++ b/lang/php-mode.el/pkg-comment
@@ -0,0 +1 @@
+Emacs lisp module for the PHP language
diff --git a/lang/php-mode.el/pkg-descr b/lang/php-mode.el/pkg-descr
new file mode 100644
index 000000000000..48183f3a9f25
--- /dev/null
+++ b/lang/php-mode.el/pkg-descr
@@ -0,0 +1,3 @@
+Emacs lisp modules for the PHP language.
+
+WWW: http://php-mode.sourceforge.net/
diff --git a/lang/php-mode.el/pkg-message b/lang/php-mode.el/pkg-message
new file mode 100644
index 000000000000..ca3200781582
--- /dev/null
+++ b/lang/php-mode.el/pkg-message
@@ -0,0 +1,4 @@
+To use php-mode in Emacs/XEmacs, add the following lines to your ~/.emacs:
+
+(autoload 'php-mode "php-mode" "Mode for editing PHP source files")
+(add-to-list 'auto-mode-alist '("\\.\\(inc\\|php[s34]?\\)" . php-mode))
diff --git a/lang/php-mode.el/pkg-plist b/lang/php-mode.el/pkg-plist
new file mode 100644
index 000000000000..8794fe5c8d1c
--- /dev/null
+++ b/lang/php-mode.el/pkg-plist
@@ -0,0 +1,6 @@
+share/emacs/site-lisp/php-mode.el
+@exec mkdir -p %D/lib/xemacs/site-lisp
+@exec ln -sf %D/%F %D/lib/xemacs/site-lisp/php-mode.el
+@unexec rm %D/lib/xemacs/site-lisp/php-mode.el
+@dirrm lib/xemacs/site-lisp
+@dirrm lib/xemacs