aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-01-31 16:36:02 +0800
committerale <ale@FreeBSD.org>2006-01-31 16:36:02 +0800
commit469baefbe117bbed26b3915dee9b4ce280c52f61 (patch)
treef1e549b5d5e1bc30330981da29ab87f45b37993f /lang/php4
parente827640b1aa78e5e1edcd95278c614d6506930fe (diff)
downloadfreebsd-ports-gnome-469baefbe117bbed26b3915dee9b4ce280c52f61.tar.gz
freebsd-ports-gnome-469baefbe117bbed26b3915dee9b4ce280c52f61.tar.zst
freebsd-ports-gnome-469baefbe117bbed26b3915dee9b4ce280c52f61.zip
Fix linking on 4.x (yes, this is another PHP configure bug).
While I'm here, replace a '=' with '+='.
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index a32ca430af68..f0f8d5adad77 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -104,9 +104,11 @@ CONFIGURE_ARGS+=--disable-cgi
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
.if defined(WITH_OPENSSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE} \