aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5-extensions
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-01-16 20:08:20 +0800
committerale <ale@FreeBSD.org>2006-01-16 20:08:20 +0800
commit223a176b09b25c0282d8d2c3e77499132df71e1e (patch)
tree3a2d5ffe3b3c869f81c7a511d48a9c07dc7b7b4c /lang/php5-extensions
parent081df03df9b317de0dabdb3786d7cef942292959 (diff)
downloadfreebsd-ports-gnome-223a176b09b25c0282d8d2c3e77499132df71e1e.tar.gz
freebsd-ports-gnome-223a176b09b25c0282d8d2c3e77499132df71e1e.tar.zst
freebsd-ports-gnome-223a176b09b25c0282d8d2c3e77499132df71e1e.zip
Update to 5.1.2 release:
- add reflection - enable xmlreader and xmlwriter by default in php5-extensions
Diffstat (limited to 'lang/php5-extensions')
-rw-r--r--lang/php5-extensions/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 684197494eb2..d1bbb2cfe67a 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -32,6 +32,8 @@ WITH_SIMPLEXML= yes
WITH_SQLITE= yes
WITH_TOKENIZER= yes
WITH_XML= yes
+WITH_XMLREADER= yes
+WITH_XMLWRITER= yes
OPTIONS= BCMATH "bc style precision math functions" off \
BZ2 "bzip2 library support" off \
@@ -88,8 +90,9 @@ OPTIONS= BCMATH "bc style precision math functions" off \
TOKENIZER "tokenizer support" on \
WDDX "WDDX support (implies XML)" off \
XML "XML support" on \
- XMLREADER "XMLReader support" off \
+ XMLREADER "XMLReader support" on \
XMLRPC "XMLRPC-EPI support" off \
+ XMLWRITER "XMLWriter support" on \
XSL "XSL support (Implies DOM)" off \
YAZ "YAZ support (ANSI/NISO Z39.50)" off \
ZIP "ZIP support" off \
@@ -110,7 +113,8 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA DBASE \
NCURSES ODBC OPENSSL PANDA PCNTL PCRE PDF PGSQL POSIX \
PSPELL READLINE RECODE SESSION SHMOP SIMPLEXML SNMP SOAP \
SOCKETS SQLITE SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
- TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XSL YAZ ZIP ZLIB
+ TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XMLWRITER XSL \
+ YAZ ZIP ZLIB
SEL_OPTIONS= yes
.for opt in ${ALL_OPTIONS}