aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php53
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2011-11-25 23:50:11 +0800
committerale <ale@FreeBSD.org>2011-11-25 23:50:11 +0800
commit13722b081ea26140fdc21dbdafd0f49739505396 (patch)
treedf0f00a00bb285a9b26577a0d73ce01c5800c8bf /lang/php53
parenta8c08196d7ff70b929a111d53e3cc7f3dcd75eae (diff)
downloadfreebsd-ports-gnome-13722b081ea26140fdc21dbdafd0f49739505396.tar.gz
freebsd-ports-gnome-13722b081ea26140fdc21dbdafd0f49739505396.tar.zst
freebsd-ports-gnome-13722b081ea26140fdc21dbdafd0f49739505396.zip
Add phar support.
Feature safe: yes
Diffstat (limited to 'lang/php53')
-rw-r--r--lang/php53/Makefile.ext8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index e57f760adcae..45878e639b21 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -269,6 +269,14 @@ USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
+.if ${PHP_MODNAME} == "phar"
+CONFIGURE_ARGS+=--enable-phar \
+ --with-pcre-dir=${LOCALBASE}
+
+USE_PHP= hash
+USE_PHP_BUILD= yes
+.endif
+
.if ${PHP_MODNAME} == "posix"
CONFIGURE_ARGS+=--enable-posix
.endif