aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php53
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-01-17 21:57:29 +0800
committerale <ale@FreeBSD.org>2006-01-17 21:57:29 +0800
commitb576f611f2c1995cde507c01a6dec820bd59252e (patch)
treebf319f36e5f98ffa0b09565770e5c47be1be2921 /lang/php53
parent9daee94689e1873413c372e207f4b38a9daffeec (diff)
downloadfreebsd-ports-gnome-b576f611f2c1995cde507c01a6dec820bd59252e.tar.gz
freebsd-ports-gnome-b576f611f2c1995cde507c01a6dec820bd59252e.tar.zst
freebsd-ports-gnome-b576f611f2c1995cde507c01a6dec820bd59252e.zip
Speed up the build of PHP extensions by extracting only the extension subdir
from the big tarball. Fix xsl extensions that look for files outside its WRKSRC.
Diffstat (limited to 'lang/php53')
-rw-r--r--lang/php53/Makefile.ext6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index b5d56d805179..c30ee22a6b3e 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -6,10 +6,13 @@ PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
DEFAULT_PHP_VER=5
BROKEN_WITH_PHP=4
-WRKSRC= ${WRKDIR}/php-${PORTVERSION:S/.r/RC/}/ext/${PHP_MODNAME}
+PHP_EXTDIR= ${DISTNAME}/ext/${PHP_MODNAME}
+WRKSRC= ${WRKDIR}/${PHP_EXTDIR}
PATCHDIR= ${.CURDIR}/files
PLIST= ${NONEXISTENT}
+EXTRACT_AFTER_ARGS?= | ${TAR} -xf - ${PHP_EXTDIR}
+
.if ${PHP_MODNAME} == "bcmath"
CONFIGURE_ARGS+=--enable-bcmath
@@ -380,6 +383,7 @@ CONFIGURE_ARGS+=--with-xsl=${LOCALBASE}
USE_GNOME= libxslt
USE_PHP= dom xml
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "zlib"