aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php53
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-06-14 22:47:26 +0800
committerale <ale@FreeBSD.org>2005-06-14 22:47:26 +0800
commita1ad353e79d2265672780d7d1b772211bffcafcf (patch)
treedf20bf0d42d65f8f9d5519f3edac89813321dc01 /lang/php53
parent7b42cce7da052274f6bfd630f3e1a18efece7227 (diff)
downloadfreebsd-ports-gnome-a1ad353e79d2265672780d7d1b772211bffcafcf.tar.gz
freebsd-ports-gnome-a1ad353e79d2265672780d7d1b772211bffcafcf.tar.zst
freebsd-ports-gnome-a1ad353e79d2265672780d7d1b772211bffcafcf.zip
Add support for Berkeley DB 4.3 and set it as default version.
PR: ports/82019 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
Diffstat (limited to 'lang/php53')
-rw-r--r--lang/php53/Makefile.ext12
1 files changed, 8 insertions, 4 deletions
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index c3774d39f8fb..01f62c8d8a4d 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -407,14 +407,18 @@ CONFIGURE_ARGS+=--with-zlib=/usr
CONFIGURE_ARGS+=--without-cdb
. endif
. if defined(WITH_DB4)
-WITH_DB4_VER?= 41
+WITH_DB4_VER?= 43
. if ${WITH_DB4_VER} == 42
-LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
+LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
+. else
+. if ${WITH_DB4_VER} == 41
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
. else
. if ${WITH_DB4_VER} == 4
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
+LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
. else
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
+LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
+. endif
. endif
. endif
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}