aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php55
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-09-14 05:31:47 +0800
committermarino <marino@FreeBSD.org>2013-09-14 05:31:47 +0800
commit7cccd8b50eb97e94310f8e167b5252e81813b64a (patch)
tree8db778c50d64049b65a48b69bb1963774cd4321d /lang/php55
parentd323712b824f849467068dc18d09090d7b77f67a (diff)
downloadfreebsd-ports-gnome-7cccd8b50eb97e94310f8e167b5252e81813b64a.tar.gz
freebsd-ports-gnome-7cccd8b50eb97e94310f8e167b5252e81813b64a.tar.zst
freebsd-ports-gnome-7cccd8b50eb97e94310f8e167b5252e81813b64a.zip
lang/php5*: Fix spl/simplexml modules (4 ports)
The simplexml module uses spl which uses pcre (php53,54,55). For php52, the fix is applied directly to spl. In any case, the bundled PCRE is not used, so it needs to be able to find the external pcre library and related headers. Unfortunately, there is no include for ${LOCALBASE}/include directory. This commit adds to fix simplexml (or spl) module build. Approved by: portmgr (bapt)
Diffstat (limited to 'lang/php55')
-rw-r--r--lang/php55/Makefile.ext1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index 9c4fba9c836f..63a7189acf12 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -334,6 +334,7 @@ CONFIGURE_ARGS+=--enable-shmop
CONFIGURE_ARGS+=--enable-simplexml \
--with-libxml-dir=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include
USES+= pkgconfig
USE_GNOME= libxml2
.endif