aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-08 16:59:28 +0800
committerpav <pav@FreeBSD.org>2009-12-08 16:59:28 +0800
commit039ed560744cf053a3249bb8a51f21c53c4510d8 (patch)
tree3c2047f4349caae94c73ccbd4d1ae651786a2bf0 /lang/php5
parentaf159121148caea633da7590cabefc0ae730239a (diff)
downloadfreebsd-ports-gnome-039ed560744cf053a3249bb8a51f21c53c4510d8.tar.gz
freebsd-ports-gnome-039ed560744cf053a3249bb8a51f21c53c4510d8.tar.zst
freebsd-ports-gnome-039ed560744cf053a3249bb8a51f21c53c4510d8.zip
- Remove support for ucd-snmp4 in ports, that also support net-snmp5.
(ucd-snmp4 port is past expiration date)
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile.ext15
1 files changed, 3 insertions, 12 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 05dbbe16da11..caab1b6c1e03 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -378,10 +378,9 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
-USE_OPENSSL= yes
-
-OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
+USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "soap"
@@ -601,14 +600,6 @@ LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
.endif
.endif
-.if ${PHP_MODNAME} == "snmp"
-. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-. else
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-. endif
-.endif
-
.if ${PHP_MODNAME} == "sqlite"
. if defined(WITH_UTF8)
CONFIGURE_ARGS+=--enable-sqlite-utf8