aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-02-09 18:02:44 +0800
committerale <ale@FreeBSD.org>2004-02-09 18:02:44 +0800
commit52594c8ef652ffa229d55836af7bae30ce43a16e (patch)
tree56bcc3a5d308386cdbc9b56b54d27360ce58ba5c /lang/php5
parent797da00177b7bf028787c09cf86bb871f27e62bf (diff)
downloadfreebsd-ports-gnome-52594c8ef652ffa229d55836af7bae30ce43a16e.tar.gz
freebsd-ports-gnome-52594c8ef652ffa229d55836af7bae30ce43a16e.tar.zst
freebsd-ports-gnome-52594c8ef652ffa229d55836af7bae30ce43a16e.zip
Fix PTHREAD_LIBS and adapt it to apache2 way.
Submitted by: Xin Li Approved by: nork (mentor/implicitly)
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index ea309e5b0386..1d27b5e2ba00 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -67,8 +67,11 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
- ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
+WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
+
+CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \