aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-01-31 16:36:02 +0800
committerale <ale@FreeBSD.org>2006-01-31 16:36:02 +0800
commit469baefbe117bbed26b3915dee9b4ce280c52f61 (patch)
treef1e549b5d5e1bc30330981da29ab87f45b37993f /lang/php5
parente827640b1aa78e5e1edcd95278c614d6506930fe (diff)
downloadfreebsd-ports-gnome-469baefbe117bbed26b3915dee9b4ce280c52f61.tar.gz
freebsd-ports-gnome-469baefbe117bbed26b3915dee9b4ce280c52f61.tar.zst
freebsd-ports-gnome-469baefbe117bbed26b3915dee9b4ce280c52f61.zip
Fix linking on 4.x (yes, this is another PHP configure bug).
While I'm here, replace a '=' with '+='.
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 4e33af8a9dca..fd677ae1c48e 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -109,9 +109,11 @@ CONFIGURE_ARGS+=--disable-cgi
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
.if defined(WITH_APACHE)
.if ${APACHE_VERSION} > 13
CONFIGURE_ARGS+=--with-apxs2=${APXS}