aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-03-13 15:10:15 +0800
committerale <ale@FreeBSD.org>2007-03-13 15:10:15 +0800
commitb099aea38548ca791d25beb2b5ccf108d5b5987c (patch)
tree566f2a2bfcdc1f162ab2ac5639cec36396afb5c1 /lang/php5
parent3b3b9a099114c03e8e667ae9e24f7541b80d8972 (diff)
downloadfreebsd-ports-gnome-b099aea38548ca791d25beb2b5ccf108d5b5987c.tar.gz
freebsd-ports-gnome-b099aea38548ca791d25beb2b5ccf108d5b5987c.tar.zst
freebsd-ports-gnome-b099aea38548ca791d25beb2b5ccf108d5b5987c.zip
Revert previous commit: for an unknown reason, the pcre module linked
with external pcre library doesn't work inside apache. PHP devs are not interested in fixing this problem and insist to use the bundled (broken too) version.
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile.ext4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 75d14fc807c6..7963d745d379 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -237,9 +237,9 @@ CONFIGURE_ARGS+=--enable-pcntl
.endif
.if ${PHP_MODNAME} == "pcre"
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+=--with-pcre-regex=yes
-CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
+PHP_HEADER_DIRS=pcrelib
.endif
.if ${PHP_MODNAME} == "pdo"