aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pike72
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-11-27 13:45:43 +0800
committeredwin <edwin@FreeBSD.org>2004-11-27 13:45:43 +0800
commit164f217d29eb1fad748d348ff6e9049c26924e1d (patch)
tree8bc89a4f44f57f82785c221beb946833812b7210 /lang/pike72
parente55d02a3d6126ec683a6b33e49a8ea549741dac5 (diff)
downloadfreebsd-ports-gnome-164f217d29eb1fad748d348ff6e9049c26924e1d.tar.gz
freebsd-ports-gnome-164f217d29eb1fad748d348ff6e9049c26924e1d.tar.zst
freebsd-ports-gnome-164f217d29eb1fad748d348ff6e9049c26924e1d.zip
[MAINTAINER] lang/pike72: Try to fix non i386 compilation breakage.
Some configuration code on Pike doesn't deal with 64bits machines (eg non x86 one). This patch is trying to fix it. PR: ports/74315 Submitted by: Xavier Beaudouin <kiwi@oav.net>
Diffstat (limited to 'lang/pike72')
-rw-r--r--lang/pike72/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 6aee9746e5e5..2fa99dabd4b4 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -28,8 +28,6 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-debug \
- --with-double-precision \
- --with-long-double-precision \
--disable-rpath \
--without-rtldebug \
--without-cdebug \
@@ -54,8 +52,8 @@ CONFIGURE_ARGS+= --without-debug \
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Build fails on !i386"
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --with-long-double-precision
.endif
PLIST_SUB+= PORTVERSION=${PORTVERSION}