aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pm3-netobj
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-10-12 04:29:34 +0800
committererwin <erwin@FreeBSD.org>2006-10-12 04:29:34 +0800
commitfd7b987d433c50f9d4d8bce1a9786011fd3554ba (patch)
tree5eb5959b203e695943e19871c1ebcb4908d2f0c9 /lang/pm3-netobj
parent5a2a5a20a0272d586015b1e2885e9e386de44606 (diff)
downloadfreebsd-ports-gnome-fd7b987d433c50f9d4d8bce1a9786011fd3554ba.tar.gz
freebsd-ports-gnome-fd7b987d433c50f9d4d8bce1a9786011fd3554ba.tar.zst
freebsd-ports-gnome-fd7b987d433c50f9d4d8bce1a9786011fd3554ba.zip
Use INST_TARGET instead of TARGETDIR locally to avoid conflicting
with bsd.ports.mk's TARGETDIR macro. Submitted by: gabor Prodded by: kris Approved by: portmgr (self)
Diffstat (limited to 'lang/pm3-netobj')
-rw-r--r--lang/pm3-netobj/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/pm3-netobj/Makefile b/lang/pm3-netobj/Makefile
index d61ee7d0e995..274641600262 100644
--- a/lang/pm3-netobj/Makefile
+++ b/lang/pm3-netobj/Makefile
@@ -24,7 +24,7 @@ DIST_SUBDIR= pm3
INSTALL_TARGET= all
MAN1= netobjd.1 stubgen.1
PLIST_SUB+= SOVERSION=${SOVERSION} TARGET=${TARGET} \
- TARGETDIR=${TARGETDIR} WORDSIZE=${WORDSIZE}
+ INST_TARGET=${INST_TARGET} WORDSIZE=${WORDSIZE}
WRKSRC= ${WRKDIRPREFIX}${.CURDIR}/../pm3-base/work/pm3-${PORTVERSION}
BUILDDIRS= network/netobjects/netobj \
@@ -42,16 +42,16 @@ USE_BZIP2= yes
.if ${PORTOBJFORMAT} == "aout"
L2= .so.${SOVERSION}.0
TARGET= FreeBSD2
-TARGETDIR= freebsd-2
+INST_TARGET= freebsd-2
WORDSIZE= 32
.elif ${ARCH} == "i386"
L2= .so.${SOVERSION}
.if ${OSVERSION} < 400011
TARGET= FreeBSD3
-TARGETDIR= freebsd-3
+INST_TARGET= freebsd-3
.else
TARGET= FreeBSD4
-TARGETDIR= freebsd-4
+INST_TARGET= freebsd-4
.endif
WORDSIZE= 32
.elif ${ARCH} == "alpha"
@@ -61,7 +61,7 @@ IGNORE= Not supported on older versions of FreeBSD/Alpha
CFLAGS+= -mieee
L2= .so.${SOVERSION}
TARGET= FBSD_ALPHA
-TARGETDIR= fbsd-alpha
+INST_TARGET= fbsd-alpha
WORDSIZE= 64
.endif