aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pnet
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-07 01:08:04 +0800
committerpav <pav@FreeBSD.org>2004-03-07 01:08:04 +0800
commit522fc4776e67815750fac0666cdb3eb5b2916081 (patch)
treee0a9c7fe241b35a8204dc93f06e313482aa51071 /lang/pnet
parent63c07cebe7a4d14eaacdf44c54be62761c03e0a8 (diff)
downloadfreebsd-ports-gnome-522fc4776e67815750fac0666cdb3eb5b2916081.tar.gz
freebsd-ports-gnome-522fc4776e67815750fac0666cdb3eb5b2916081.tar.zst
freebsd-ports-gnome-522fc4776e67815750fac0666cdb3eb5b2916081.zip
Revive lang/pnet, a "DotGNU" Portable.NET C# compiler suite. It came back
as a bunch of ports and a meta-port. ml-pnet: Some of the Mono upper-level libraries in a form that can be easily compiled and used with pnet's CLI implementation. pnet: A meta-port for all these ports. pnet-base: A runtime engine, C# compiler and a host of useful development tools, all written in C. pnetc: pnetC project, an ANSI C library that can be compiled down to IL using Portable.NET's cscc compiler. pnetlib: C# class libraries. PR: ports/60408, ports/60409, ports/60413, ports/60453 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'lang/pnet')
-rw-r--r--lang/pnet/Makefile29
-rw-r--r--lang/pnet/Makefile.pnet21
-rw-r--r--lang/pnet/pkg-descr7
-rw-r--r--lang/pnet/pkg-plist1
4 files changed, 58 insertions, 0 deletions
diff --git a/lang/pnet/Makefile b/lang/pnet/Makefile
new file mode 100644
index 000000000000..da0c93a088e1
--- /dev/null
+++ b/lang/pnet/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gnome2
+# Date created: 21 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnet
+PORTVERSION= ${PNET_VERSION}
+CATEGORIES= lang
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= ahze@ahze.net
+COMMENT= The "meta-port" for DotGNU Portable.NET
+
+BUILD_DEPENDS= treecc:${PORTSDIR}/lang/treecc
+RUN_DEPENDS= cscc:${PORTSDIR}/lang/pnet-base \
+ csunit:${PORTSDIR}/lang/pnetlib \
+ sqlsharp-pnet:${PORTSDIR}/lang/ml-pnet \
+ ${LOCALBASE}/lib/cscc/lib/libc64.dll:${PORTSDIR}/lang/pnetc
+
+NO_BUILD= yes
+
+do-install: # empty
+
+.include "../pnet/Makefile.pnet"
+.include <bsd.port.mk>
diff --git a/lang/pnet/Makefile.pnet b/lang/pnet/Makefile.pnet
new file mode 100644
index 000000000000..2fa76cdc3028
--- /dev/null
+++ b/lang/pnet/Makefile.pnet
@@ -0,0 +1,21 @@
+PNET_VERSION= 0.6.0
+PNET_REVISION= 0
+PNET_PORTVER= ${PNET_VERSION}.${PNET_REVISION}
+PNET_PORTREV= 0
+PNET_PORTEPOCH= 0
+
+PNET_MASTER_SITES= http://www.southern-storm.com.au/download/
+
+ILSTRIP_CMD= ${LOCALBASE}/bin/ilstrip
+
+.if defined(WITH_OPTIMIZED_CSFLAGS)
+CSFLAGS=-02
+.endif
+
+pre-everything:: post-everything
+.if !defined(WITH_OPTIMIZED_CSFLAGS)
+ @${ECHO_MSG} "Define optimized CSLAGS with"
+ @${ECHO_MSG} "WITH_OPTIMIZED_CSFLAGS=yes"
+.endif
+
+post-everything::
diff --git a/lang/pnet/pkg-descr b/lang/pnet/pkg-descr
new file mode 100644
index 000000000000..c2eb7f2e7be8
--- /dev/null
+++ b/lang/pnet/pkg-descr
@@ -0,0 +1,7 @@
+Meta-port package for pnet.
+
+DotGNU Portable.NET contains a runtime engine, C# compiler, and a host of
+useful development tools, all written in C. This package is generally
+referred to as "pnet".
+
+WWW: http://www.southern-storm.com.au/portable_net.html
diff --git a/lang/pnet/pkg-plist b/lang/pnet/pkg-plist
new file mode 100644
index 000000000000..549a621fec0c
--- /dev/null
+++ b/lang/pnet/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty