aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pnetc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-07 01:08:04 +0800
committerpav <pav@FreeBSD.org>2004-03-07 01:08:04 +0800
commit522fc4776e67815750fac0666cdb3eb5b2916081 (patch)
treee0a9c7fe241b35a8204dc93f06e313482aa51071 /lang/pnetc
parent63c07cebe7a4d14eaacdf44c54be62761c03e0a8 (diff)
downloadfreebsd-ports-gnome-522fc4776e67815750fac0666cdb3eb5b2916081.tar.gz
freebsd-ports-gnome-522fc4776e67815750fac0666cdb3eb5b2916081.tar.zst
freebsd-ports-gnome-522fc4776e67815750fac0666cdb3eb5b2916081.zip
Revive lang/pnet, a "DotGNU" Portable.NET C# compiler suite. It came back
as a bunch of ports and a meta-port. ml-pnet: Some of the Mono upper-level libraries in a form that can be easily compiled and used with pnet's CLI implementation. pnet: A meta-port for all these ports. pnet-base: A runtime engine, C# compiler and a host of useful development tools, all written in C. pnetc: pnetC project, an ANSI C library that can be compiled down to IL using Portable.NET's cscc compiler. pnetlib: C# class libraries. PR: ports/60408, ports/60409, ports/60413, ports/60453 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'lang/pnetc')
-rw-r--r--lang/pnetc/Makefile23
-rw-r--r--lang/pnetc/distinfo1
-rw-r--r--lang/pnetc/pkg-descr5
-rw-r--r--lang/pnetc/pkg-plist59
4 files changed, 88 insertions, 0 deletions
diff --git a/lang/pnetc/Makefile b/lang/pnetc/Makefile
new file mode 100644
index 000000000000..995cc71c1961
--- /dev/null
+++ b/lang/pnetc/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: treecc
+# Date created: Wed Jul 11 00:45:15 EDT 2001
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnetC
+PORTVERSION= ${PNET_VERSION}
+CATEGORIES= lang
+MASTER_SITES= ${PNET_MASTER_SITES}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= ANSI-compatible C library for pnet's cscc compiler
+
+LIB_DEPENDS= XsharpSupport.0:${PORTSDIR}/lang/pnetlib
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+STRIP= # Nothing to be stripped.
+
+.include "${.CURDIR}/../pnet/Makefile.pnet"
+.include <bsd.port.mk>
diff --git a/lang/pnetc/distinfo b/lang/pnetc/distinfo
new file mode 100644
index 000000000000..845a0840c8ad
--- /dev/null
+++ b/lang/pnetc/distinfo
@@ -0,0 +1 @@
+MD5 (pnetC-0.6.0.tar.gz) = e076377cdd64b499ebe8a5356c2129fc
diff --git a/lang/pnetc/pkg-descr b/lang/pnetc/pkg-descr
new file mode 100644
index 000000000000..22c932b74a82
--- /dev/null
+++ b/lang/pnetc/pkg-descr
@@ -0,0 +1,5 @@
+This is the "pnetC" project. The goal of the project is to create
+an ANSI-compatible C library, that can be compiled down to IL using
+Portable.NET's "cscc" compiler.
+
+WWW: http://www.southern-storm.com.au/portable_net.html
diff --git a/lang/pnetc/pkg-plist b/lang/pnetc/pkg-plist
new file mode 100644
index 000000000000..400118109b4f
--- /dev/null
+++ b/lang/pnetc/pkg-plist
@@ -0,0 +1,59 @@
+lib/cscc/lib/libc64.dll
+lib/cscc/lib/libm64.dll
+share/cscc/include/alloca.h
+share/cscc/include/assert.h
+share/cscc/include/bits/libc-lock.h
+share/cscc/include/bits/local_lim.h
+share/cscc/include/bits/mman.h
+share/cscc/include/bits/posix1_lim.h
+share/cscc/include/bits/posix2_lim.h
+share/cscc/include/bits/stat.h
+share/cscc/include/bits/stdio_lim.h
+share/cscc/include/bits/types.h
+share/cscc/include/bits/waitflags.h
+share/cscc/include/bits/waitstatus.h
+share/cscc/include/bits/wchar.h
+share/cscc/include/bits/wordsize.h
+share/cscc/include/bits/xopen_lim.h
+share/cscc/include/ctype.h
+share/cscc/include/dirent.h
+share/cscc/include/errno.h
+share/cscc/include/fcntl.h
+share/cscc/include/features.h
+share/cscc/include/gmp-mparam.h
+share/cscc/include/gmp.h
+share/cscc/include/gnu/stubs.h
+share/cscc/include/ieee754.h
+share/cscc/include/inttypes.h
+share/cscc/include/limits.h
+share/cscc/include/malloc.h
+share/cscc/include/math.h
+share/cscc/include/pthread.h
+share/cscc/include/pwd.h
+share/cscc/include/setjmp.h
+share/cscc/include/stdarg.h
+share/cscc/include/stdbool.h
+share/cscc/include/stddef.h
+share/cscc/include/stdint.h
+share/cscc/include/stdio.h
+share/cscc/include/stdio_ext.h
+share/cscc/include/stdlib.h
+share/cscc/include/string.h
+share/cscc/include/strings.h
+share/cscc/include/sys/cdefs.h
+share/cscc/include/sys/errno.h
+share/cscc/include/sys/mman.h
+share/cscc/include/sys/stat.h
+share/cscc/include/sys/sysmacros.h
+share/cscc/include/sys/types.h
+share/cscc/include/time.h
+share/cscc/include/unistd.h
+share/cscc/include/varargs.h
+share/cscc/include/wchar.h
+share/cscc/include/wctype.h
+share/cscc/include/xlocale.h
+@dirrm share/cscc/include/bits
+@dirrm share/cscc/include/gnu
+@dirrm share/cscc/include/sys
+@dirrm share/cscc/include
+@dirrm share/cscc