aboutsummaryrefslogtreecommitdiffstats
path: root/lang/polyml/Makefile
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-04-16 03:58:03 +0800
committerpi <pi@FreeBSD.org>2016-04-16 03:58:03 +0800
commita543209433d2c2c0049ede0e25d9c900e4c6bbc9 (patch)
treeda977d79608e52cdb2af4c638f4205958d7b4c4e /lang/polyml/Makefile
parent2f425e9331456fa0758e2383f6bad4fcd8bcfa24 (diff)
downloadfreebsd-ports-gnome-a543209433d2c2c0049ede0e25d9c900e4c6bbc9.tar.gz
freebsd-ports-gnome-a543209433d2c2c0049ede0e25d9c900e4c6bbc9.tar.zst
freebsd-ports-gnome-a543209433d2c2c0049ede0e25d9c900e4c6bbc9.zip
lang/polyml: 5.5.2 -> 5.6
Changes: - New foreign-function interface (Foreign structure). - Reimplemented debugger so that code with debugging enabled is much faster. - Improved support for Poly/ML on native Windows. - Support for MIPS and 64-bit ARM processors through the byte-code interpreter. - Various bug fixes. PR: 208783, 199566 Submitted by: Phil Eaton <philneaton95@gmail.com>, brooks Approved by: Timothy Beyer <beyert@cs.ucr.edu> (maintainer)
Diffstat (limited to 'lang/polyml/Makefile')
-rw-r--r--lang/polyml/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index cbafc283e11f..620bf879fdae 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= polyml
-PORTVERSION= 5.5.2
-PORTREVISION= 2
+PORTVERSION= 5.6
CATEGORIES= lang
-MASTER_SITES= SF
DISTNAME= ${PORTNAME}.${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
@@ -18,6 +16,9 @@ LIB_DEPENDS= libffi.so:devel/libffi
ONLY_FOR_ARCHS= i386 amd64
+USE_GITHUB= yes
+GH_TUPLE= polyml:polyml:v5.6
+
USES= libtool pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-system-libffi --enable-shared