aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pypy-devel
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2013-11-07 23:08:55 +0800
committerdbn <dbn@FreeBSD.org>2013-11-07 23:08:55 +0800
commit751c3cd24be4711292276f991c1a3ce65922d115 (patch)
tree34f41f090da546acbf40cab165aef2cc8b07bb9e /lang/pypy-devel
parentc36240fcc38dcd56e7279d0a36115c7aba22c957 (diff)
downloadfreebsd-ports-gnome-751c3cd24be4711292276f991c1a3ce65922d115.tar.gz
freebsd-ports-gnome-751c3cd24be4711292276f991c1a3ce65922d115.tar.zst
freebsd-ports-gnome-751c3cd24be4711292276f991c1a3ce65922d115.zip
Add stage support to lang/pypy, lang/pypy-devel and lang/pypy3-devel.
Also, require a modern compiler that can handle c11. Although this is not strictly required (just about any C compiler would do) the base GCC compiler has a memory bug and thus cannot reasonably compile the ports.
Diffstat (limited to 'lang/pypy-devel')
-rw-r--r--lang/pypy-devel/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/lang/pypy-devel/Makefile b/lang/pypy-devel/Makefile
index 2afcba67051b..6a2a2d7fd87b 100644
--- a/lang/pypy-devel/Makefile
+++ b/lang/pypy-devel/Makefile
@@ -15,9 +15,9 @@ COMMENT= Fast, compliant implementation of the Python language
LICENSE= MIT PSFL
LICENSE_COMB= multi
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
- ffi:${PORTSDIR}/devel/libffi \
- sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libffi.so:${PORTSDIR}/devel/libffi \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3
PYTHON_DESC= Use Python-2.7 to translate (slowest)
PYPY_DESC= Use PyPy to translate (fastest, highest memory usage)
@@ -44,7 +44,7 @@ BUILD_WRKSRC= ${WRKDIR}
COMMIT= ab7580454b32
DATE= 20130810
USE_BZIP2= yes
-USES= gettext iconv
+USES= compiler:c11 gettext iconv
MAKEFILE= ${FILESDIR}/Makefile
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
@@ -67,18 +67,9 @@ MAKE_ENV+= DISTVERSION=${DISTVERSION} PYTHON_CMD=${PYTHON_CMD} \
LOCALBASE_REFIX= \
lib_pypy/_sqlite3.py
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include "${MASTERDIR}/files/bsd.pypy.inst.mk"
-.if ${OSVERSION} < 1000024 || ( ${ARCH} != "i386" && ${ARCH} != "amd64" )
-.if ${CC:T} == cc && ( exists(/usr/bin/clang) || exists(${LOCALBASE}/clang) )
-CC= clang
-.else
-USE_GCC= 4.2+
-.endif
-.endif
-
.if ${PORT_OPTIONS:MPYPY} || defined(PYTHON_CMD)
PYTHON_CMD?= ${LOCALBASE}/bin/pypy
.elif ${PORT_OPTIONS:MPYPY_MINMEM}
@@ -116,7 +107,7 @@ WITH_BOEHM_GC= yes
.endfor # inst in ${PYPY_INST}
.if defined(WITH_BOEHM_GC)
-LIB_DEPENDS+= gc:${PORTSDIR}/devel/boehm-gc
+LIB_DEPENDS+= libgc.so:${PORTSDIR}/devel/boehm-gc
.endif
# Translate FreeBSD ARCH types to PyPy ARCH types
@@ -274,12 +265,12 @@ post-build:
do-install:
.for _path in ${PYPYDIRS}
- -${RM} ${PREFIX}/${_path:C/.*://}
- (cd ${WRKSRC}/${_path:C/:.*//}; ${COPYTREE_SHARE} . ${PREFIX}/${_path:C/.*://})
+ ${RM} -f ${STAGEDIR}${PREFIX}/${_path:C/.*://}
+ (cd ${WRKSRC}/${_path:C/:.*//}; ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${_path:C/.*://})
.endfor
.for name in ${PYPY_NAMES:O}
${STRIP_CMD} ${WRKDIR}/${name}
- ${INSTALL_PROGRAM} ${WRKDIR}/${name} ${PREFIX}/bin/${name}-${PYPY_VER}
+ ${INSTALL_PROGRAM} ${WRKDIR}/${name} ${STAGEDIR}${PREFIX}/bin/${name}-${PYPY_VER}
${ECHO} bin/${name}-${PYPY_VER} >> ${TMPPLIST}
.endfor