aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pypy
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-20 20:02:07 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-20 20:02:07 +0800
commit56d511a435a8db91cbb7081bd0f4fb30317ea7a2 (patch)
treef214fd97b3e397fb90830db2b455ad9033c3e640 /lang/pypy
parent4770a591dedae73a35dfec66e21ed33765da0890 (diff)
downloadfreebsd-ports-gnome-56d511a435a8db91cbb7081bd0f4fb30317ea7a2.tar.gz
freebsd-ports-gnome-56d511a435a8db91cbb7081bd0f4fb30317ea7a2.tar.zst
freebsd-ports-gnome-56d511a435a8db91cbb7081bd0f4fb30317ea7a2.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Diffstat (limited to 'lang/pypy')
-rw-r--r--lang/pypy/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index 16e80900fbe2..ffe163247739 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -24,6 +24,9 @@ TEST_DEPENDS= ${LOCALBASE}/${PYPY_DIR}/lib_pypy/_gdbm_cffi.${PYPY_CFFI_VER}.so:d
ONLY_FOR_ARCHS?=i386 amd64 armv6 powerpc64
ONLY_FOR_ARCHS_REASON?= PyPy JIT only supported on these architectures
+BROKEN_armv6= fails to package: pypy_objspace_std.c: Crash in JIT!
+BROKEN_powerpc64= fails to compile: platcheck_109.c: fatal error: linux/auxvec.h: No such file or directory
+
OPTIONS_SINGLE= TRANS
OPTIONS_SINGLE_TRANS= PYTHON
PYTHON_DESC= Use Python-2.7 to translate (slowest)