aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pypy
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2018-01-08 03:32:34 +0800
committerkrion <krion@FreeBSD.org>2018-01-08 03:32:34 +0800
commitf5e0c994186ee70d6883d958d401bd304c4f19f0 (patch)
treeba5e9a0c1e46c60e7f5166e6605cf4b10b4b31bf /lang/pypy
parentd9f137bc4193b721f1bbc6f81fb088173a0ff49a (diff)
downloadfreebsd-ports-gnome-f5e0c994186ee70d6883d958d401bd304c4f19f0.tar.gz
freebsd-ports-gnome-f5e0c994186ee70d6883d958d401bd304c4f19f0.tar.zst
freebsd-ports-gnome-f5e0c994186ee70d6883d958d401bd304c4f19f0.zip
Set LLD_UNSAFE=yes that the port will continue to link with ld.bfd
if /usr/bin/ld is lld, until the issue can be addressed. PR: 214864 Approved by: portmgr (LLD_UNSAFE blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'lang/pypy')
-rw-r--r--lang/pypy/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index f59a9b61ab6a..2a94f9d7b72e 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -49,6 +49,7 @@ BUILD_WRKSRC?= ${WRKDIR}/build/usession-release-pypy2.7-v${DISTVERSION}-0/testin
MAKE_ENV+= PYPY_LOCALBASE=${LOCALBASE} LDSHARED="${CC} -shared"
PACKAGE_ARGS?= --without-gdbm --without-sqlite3 --without-tk
USE_LDCONFIG= ${PREFIX}/${PYPY_DIR}/bin
+LLD_UNSAFE= yes
USES= gettext-runtime gmake shebangfix ssl tar:bzip2
SHEBANG_FILES?= lib-python/2.7/plat-mac/appletrunner.py \
lib-python/2.7/plat-mac/bundlebuilder.py \