aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pypy
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2017-04-14 20:37:51 +0800
committerdbn <dbn@FreeBSD.org>2017-04-14 20:37:51 +0800
commitf59da7e00cc4535fa2ca25d1b413bc9e5ddc91f8 (patch)
tree191b36883493af01f8663d4af723cd4280c6cf72 /lang/pypy
parent04141b78f9e569f710643533823aac3b0d01e436 (diff)
downloadfreebsd-ports-gnome-f59da7e00cc4535fa2ca25d1b413bc9e5ddc91f8.tar.gz
freebsd-ports-gnome-f59da7e00cc4535fa2ca25d1b413bc9e5ddc91f8.tar.zst
freebsd-ports-gnome-f59da7e00cc4535fa2ca25d1b413bc9e5ddc91f8.zip
lang/pypy(3): unbreak build, fix shebang
- Fix shebang references to pypy(3) - pypy3i [1]: - Correctly set ONLY_FOR_ARCHS - Remove '.swn' files from pkg-plist Reported by: pkg-fallout [1]
Diffstat (limited to 'lang/pypy')
-rw-r--r--lang/pypy/Makefile45
1 files changed, 41 insertions, 4 deletions
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index 9e1f831a4024..7f9574901904 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -3,6 +3,7 @@
PORTNAME?= pypy
DISTVERSION?= 5.7.1 # Also update bsd.pypy.cffi.mk
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= https://bitbucket.org/pypy/pypy/downloads/ http://buildbot.pypy.org/mirror/
DISTNAME?= ${PORTNAME}2-v${PORTVERSION}-src
@@ -20,8 +21,8 @@ TEST_DEPENDS= ${LOCALBASE}/${PYPY_DIR}/lib_pypy/_gdbm_cffi.${PYPY_CFFI_VER}.so:d
${LOCALBASE}/${PYPY_DIR}/lib_pypy/_sqlite3_cffi.${PYPY_CFFI_VER}.so:databases/pypy-sqlite3 \
${LOCALBASE}/${PYPY_DIR}/lib_pypy/_tkinter/tklib_cffi.${PYPY_CFFI_VER}.so:x11-toolkits/pypy-tkinter
-ONLY_FOR_ARCHS= i386 amd64 armv6 powerpc64
-ONLY_FOR_ARCHS_REASON= PyPy JIT only supported on these architectures
+ONLY_FOR_ARCHS?=i386 amd64 armv6 powerpc64
+ONLY_FOR_ARCHS_REASON?= PyPy JIT only supported on these architectures
OPTIONS_SINGLE= TRANS
OPTIONS_SINGLE_TRANS= PYTHON
@@ -46,7 +47,42 @@ BUILD_WRKSRC?= ${WRKDIR}/build/usession-release-pypy2.7-v${PORTVERSION}-0/testin
MAKE_ENV+= PYPY_LOCALBASE=${LOCALBASE} LDSHARED="${CC} -shared"
PACKAGE_ARGS?= --without-gdbm --without-sqlite3 --without-tk
USE_LDCONFIG= ${PREFIX}/${PYPY_DIR}/bin
-USES= gettext-runtime gmake ssl tar:bzip2
+USES= gettext-runtime gmake shebangfix ssl tar:bzip2
+SHEBANG_FILES?= lib-python/2.7/plat-mac/appletrunner.py \
+ lib-python/2.7/plat-mac/bundlebuilder.py \
+ lib-python/2.7/keyword.py \
+ lib-python/2.7/test/regrtest.py \
+ lib-python/2.7/test/pystone.py \
+ lib-python/2.7/test/curses_tests.py \
+ lib-python/2.7/test/re_tests.py \
+ lib-python/2.7/test/crashers/recursive_call.py \
+ lib-python/2.7/UserString.py \
+ lib-python/2.7/pdb.py \
+ lib-python/2.7/mimify.py \
+ lib-python/2.7/pydoc.py \
+ lib-python/2.7/uu.py \
+ lib-python/2.7/trace.py \
+ lib-python/2.7/platform.py \
+ lib-python/2.7/profile.py \
+ lib-python/2.7/tabnanny.py \
+ lib-python/2.7/lib2to3/tests/pytree_idempotency.py \
+ lib-python/2.7/lib2to3/tests/data/false_encoding.py \
+ lib-python/2.7/lib2to3/tests/data/different_encoding.py \
+ lib-python/2.7/lib2to3/pgen2/token.py \
+ lib-python/2.7/encodings/rot_13.py \
+ lib-python/2.7/base64.py \
+ lib-python/2.7/webbrowser.py \
+ lib-python/2.7/idlelib/PyShell.py \
+ lib-python/2.7/cgi.py \
+ lib-python/2.7/symbol.py \
+ lib-python/2.7/cProfile.py \
+ lib-python/2.7/smtpd.py \
+ lib-python/2.7/quopri.py \
+ lib-python/2.7/timeit.py \
+ lib-python/2.7/smtplib.py
+
+python_OLD_CMD= /usr/local/bin/python
+python_CMD= ${PREFIX}/bin/${PORTNAME}
.if ${PORTNAME} != pypy
PYPY_BUILD_DEPENDS= pypy:lang/pypy
@@ -116,10 +152,11 @@ pkg-plist: stage
${REINPLACE_CMD} -e 's|^${PYPY_DIR}|%%PYPY_DIR%%|g' \
-e 's|_${PYPY_BITS}_|_%%PYPY_BITS%%_|g' \
-e 's|${PYPY_CFFI_VER}|%%PYPY_CFFI_VER%%|g' \
+ -e 's/\(.*\/__pycache__\)\/$$/@dir \1/g' \
-e '/\/$$/d' \
${WRKDIR}/.plist-files-gen
${ECHO} bin/${PORTNAME} > ${WRKDIR}/pkg-plist
- ${SORT} ${WRKDIR}/.plist-files-gen >> ${WRKDIR}/pkg-plist
+ ${SORT} ${WRKDIR}/.plist-files-gen | ${GREP} -v '\.swn$$\|\.orig' >> ${WRKDIR}/pkg-plist
${CP} ${WRKDIR}/pkg-plist ${.CURDIR}/pkg-plist
.include <bsd.port.post.mk>