aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python-doc-html
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-05-16 19:41:37 +0800
committertg <tg@FreeBSD.org>2001-05-16 19:41:37 +0800
commit41ec26a41d12c9fc06276285c932fc2ff4379e9c (patch)
treed84467e197014c2400b4ecab1e87b29fe5149741 /lang/python-doc-html
parentf4e2b06d0ca0b4c36b9a541db799d2a11c104076 (diff)
downloadfreebsd-ports-gnome-41ec26a41d12c9fc06276285c932fc2ff4379e9c.tar.gz
freebsd-ports-gnome-41ec26a41d12c9fc06276285c932fc2ff4379e9c.tar.zst
freebsd-ports-gnome-41ec26a41d12c9fc06276285c932fc2ff4379e9c.zip
Fix PLIST for Python-2.1 docs.
Diffstat (limited to 'lang/python-doc-html')
-rw-r--r--lang/python-doc-html/Makefile9
-rw-r--r--lang/python-doc-html/files/plist-html-2.1.diff415
2 files changed, 423 insertions, 1 deletions
diff --git a/lang/python-doc-html/Makefile b/lang/python-doc-html/Makefile
index 5472f665c15c..8c8cd29cae6d 100644
--- a/lang/python-doc-html/Makefile
+++ b/lang/python-doc-html/Makefile
@@ -18,9 +18,10 @@ DIST_SUBDIR= python
USE_PYTHON= yes
USE_BZIP2= yes
NO_BUILD= yes
-PLIST= ${PKGDIR}/pkg-plist_${DOCFORMAT}
+PLIST= ${WRKDIR}/pkg-plist_${DOCFORMAT}
DOCDIR= ${PREFIX}/share/doc/${PYTHON_VERSION}
+PLIST_DIFF= ${FILESDIR}/plist-${DOCFORMAT}-${PORTVERSION}.diff
DOCFORMAT?= html
@@ -36,6 +37,12 @@ do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
+pre-install:
+ @${CP} ${PKGDIR}/pkg-plist_${DOCFORMAT} ${WRKDIR}
+ @if [ -f ${PLIST_DIFF} ]; then \
+ cd ${WRKDIR} && patch -p --quiet < ${PLIST_DIFF}; \
+ fi
+
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCDIR}
diff --git a/lang/python-doc-html/files/plist-html-2.1.diff b/lang/python-doc-html/files/plist-html-2.1.diff
new file mode 100644
index 000000000000..37626f4c8583
--- /dev/null
+++ b/lang/python-doc-html/files/plist-html-2.1.diff
@@ -0,0 +1,415 @@
+--- pkg-plist_html Wed May 2 14:01:35 2001
++++ pkg-plist_html_2.1 Thu May 10 15:18:32 2001
+@@ -17,2 +17,3 @@
+ share/doc/%%PYTHON_VERSION%%/api/embedding.html
++share/doc/%%PYTHON_VERSION%%/api/example-cycle-support.html
+ share/doc/%%PYTHON_VERSION%%/api/exceptionHandling.html
+@@ -28,2 +29,3 @@
+ share/doc/%%PYTHON_VERSION%%/api/initialization.html
++share/doc/%%PYTHON_VERSION%%/api/instanceObjects.html
+ share/doc/%%PYTHON_VERSION%%/api/intObjects.html
+@@ -61,2 +63,3 @@
+ share/doc/%%PYTHON_VERSION%%/api/stringObjects.html
++share/doc/%%PYTHON_VERSION%%/api/supporting-cycle-detection.html
+ share/doc/%%PYTHON_VERSION%%/api/threads.html
+@@ -69,48 +72,8 @@
+ share/doc/%%PYTHON_VERSION%%/api/veryhigh.html
+-share/doc/%%PYTHON_VERSION%%/dist/about.html
+ share/doc/%%PYTHON_VERSION%%/dist/bdist-cmds.html
+-share/doc/%%PYTHON_VERSION%%/dist/build-clib-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/build-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/build-cmds.html
+-share/doc/%%PYTHON_VERSION%%/dist/build-ext-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/build-py-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/built-dist.html
+-share/doc/%%PYTHON_VERSION%%/dist/clean-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/concepts.html
+-share/doc/%%PYTHON_VERSION%%/dist/contents.html
+-share/doc/%%PYTHON_VERSION%%/dist/creating-dumb.html
+-share/doc/%%PYTHON_VERSION%%/dist/creating-rpms.html
+ share/doc/%%PYTHON_VERSION%%/dist/creating-wininst.html
+-share/doc/%%PYTHON_VERSION%%/dist/describing-extensions.html
+ share/doc/%%PYTHON_VERSION%%/dist/dist.css
+ share/doc/%%PYTHON_VERSION%%/dist/dist.html
+-share/doc/%%PYTHON_VERSION%%/dist/distutils-term.html
+-share/doc/%%PYTHON_VERSION%%/dist/examples.html
+-share/doc/%%PYTHON_VERSION%%/dist/extend-existing.html
+-share/doc/%%PYTHON_VERSION%%/dist/extending.html
+ share/doc/%%PYTHON_VERSION%%/dist/index.html
+-share/doc/%%PYTHON_VERSION%%/dist/install-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/install-data-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/install-lib-cmd.html
+-share/doc/%%PYTHON_VERSION%%/dist/install-scripts-cmd.html
+ share/doc/%%PYTHON_VERSION%%/dist/intro.html
+-share/doc/%%PYTHON_VERSION%%/dist/listing-modules.html
+-share/doc/%%PYTHON_VERSION%%/dist/listing-packages.html
+-share/doc/%%PYTHON_VERSION%%/dist/manifest-options.html
+-share/doc/%%PYTHON_VERSION%%/dist/manifest.html
+-share/doc/%%PYTHON_VERSION%%/dist/multiple-ext.html
+-share/doc/%%PYTHON_VERSION%%/dist/new-commands.html
+-share/doc/%%PYTHON_VERSION%%/dist/node11.html
+-share/doc/%%PYTHON_VERSION%%/dist/node12.html
+-share/doc/%%PYTHON_VERSION%%/dist/node13.html
+-share/doc/%%PYTHON_VERSION%%/dist/node14.html
+-share/doc/%%PYTHON_VERSION%%/dist/node28.html
+-share/doc/%%PYTHON_VERSION%%/dist/node45.html
+-share/doc/%%PYTHON_VERSION%%/dist/node46.html
+-share/doc/%%PYTHON_VERSION%%/dist/node47.html
+-share/doc/%%PYTHON_VERSION%%/dist/node48.html
+-share/doc/%%PYTHON_VERSION%%/dist/pure-mod.html
+-share/doc/%%PYTHON_VERSION%%/dist/pure-pkg.html
+-share/doc/%%PYTHON_VERSION%%/dist/python-terms.html
+-share/doc/%%PYTHON_VERSION%%/dist/reference.html
+ share/doc/%%PYTHON_VERSION%%/dist/sdist-cmd.html
+@@ -119,3 +82,2 @@
+ share/doc/%%PYTHON_VERSION%%/dist/simple-example.html
+-share/doc/%%PYTHON_VERSION%%/dist/single-ext.html
+ share/doc/%%PYTHON_VERSION%%/dist/source-dist.html
+@@ -133,4 +95,2 @@
+ share/doc/%%PYTHON_VERSION%%/doc/meta-info.html
+-share/doc/%%PYTHON_VERSION%%/doc/node10.html
+-share/doc/%%PYTHON_VERSION%%/doc/node11.html
+ share/doc/%%PYTHON_VERSION%%/doc/node12.html
+@@ -138,4 +98,4 @@
+ share/doc/%%PYTHON_VERSION%%/doc/node14.html
+-share/doc/%%PYTHON_VERSION%%/doc/node17.html
+-share/doc/%%PYTHON_VERSION%%/doc/node18.html
++share/doc/%%PYTHON_VERSION%%/doc/node15.html
++share/doc/%%PYTHON_VERSION%%/doc/node16.html
+ share/doc/%%PYTHON_VERSION%%/doc/node19.html
+@@ -143,4 +103,8 @@
+ share/doc/%%PYTHON_VERSION%%/doc/node20.html
++share/doc/%%PYTHON_VERSION%%/doc/node21.html
++share/doc/%%PYTHON_VERSION%%/doc/node22.html
+ share/doc/%%PYTHON_VERSION%%/doc/node3.html
++share/doc/%%PYTHON_VERSION%%/doc/node5.html
+ share/doc/%%PYTHON_VERSION%%/doc/node6.html
++share/doc/%%PYTHON_VERSION%%/doc/node8.html
+ share/doc/%%PYTHON_VERSION%%/doc/preamble-info.html
+@@ -158,3 +122,6 @@
+ share/doc/%%PYTHON_VERSION%%/ext/custom-interps.html
++share/doc/%%PYTHON_VERSION%%/ext/defining-new-types.html
+ share/doc/%%PYTHON_VERSION%%/ext/distributing.html
++share/doc/%%PYTHON_VERSION%%/ext/dnt-basics.html
++share/doc/%%PYTHON_VERSION%%/ext/dnt-type-methods.html
+ share/doc/%%PYTHON_VERSION%%/ext/dynamic-linking.html
+@@ -187,22 +154,10 @@
+ share/doc/%%PYTHON_VERSION%%/icons/index.gif
+-share/doc/%%PYTHON_VERSION%%/icons/labslogo.gif
+ share/doc/%%PYTHON_VERSION%%/icons/modules.gif
+ share/doc/%%PYTHON_VERSION%%/icons/next.gif
+-share/doc/%%PYTHON_VERSION%%/icons/offsite.gif
+ share/doc/%%PYTHON_VERSION%%/icons/previous.gif
+-share/doc/%%PYTHON_VERSION%%/icons/pythonlabs.gif
+ share/doc/%%PYTHON_VERSION%%/icons/up.gif
+ share/doc/%%PYTHON_VERSION%%/index.html
+-share/doc/%%PYTHON_VERSION%%/inst/about.html
+-share/doc/%%PYTHON_VERSION%%/inst/alt-install-home.html
+-share/doc/%%PYTHON_VERSION%%/inst/alt-install-macos.html
+-share/doc/%%PYTHON_VERSION%%/inst/alt-install-prefix.html
+ share/doc/%%PYTHON_VERSION%%/inst/alt-install-windows.html
+-share/doc/%%PYTHON_VERSION%%/inst/alt-install.html
+-share/doc/%%PYTHON_VERSION%%/inst/building-ext.html
+-share/doc/%%PYTHON_VERSION%%/inst/config-files.html
+-share/doc/%%PYTHON_VERSION%%/inst/contents.html
++share/doc/%%PYTHON_VERSION%%/inst/config-syntax.html
+ share/doc/%%PYTHON_VERSION%%/inst/custom-install.html
+-share/doc/%%PYTHON_VERSION%%/inst/how-build-works.html
+-share/doc/%%PYTHON_VERSION%%/inst/how-install-works.html
+ share/doc/%%PYTHON_VERSION%%/inst/index.html
+@@ -210,11 +165,3 @@
+ share/doc/%%PYTHON_VERSION%%/inst/inst.html
+-share/doc/%%PYTHON_VERSION%%/inst/intro.html
+-share/doc/%%PYTHON_VERSION%%/inst/makefile-pre-in.html
+-share/doc/%%PYTHON_VERSION%%/inst/manual-install.html
+-share/doc/%%PYTHON_VERSION%%/inst/new-standard.html
+-share/doc/%%PYTHON_VERSION%%/inst/non-ms-compilers.html
+-share/doc/%%PYTHON_VERSION%%/inst/old-way.html
+-share/doc/%%PYTHON_VERSION%%/inst/platform-variations.html
+ share/doc/%%PYTHON_VERSION%%/inst/pre-distutils.html
+-share/doc/%%PYTHON_VERSION%%/inst/splitting-up.html
+ share/doc/%%PYTHON_VERSION%%/inst/standard-install.html
+@@ -233,3 +180,2 @@
+ share/doc/%%PYTHON_VERSION%%/lib/Functions_in_cgi_module.html
+-share/doc/%%PYTHON_VERSION%%/lib/HTTP_Examples.html
+ share/doc/%%PYTHON_VERSION%%/lib/MimeWriter-objects.html
+@@ -251,2 +197,4 @@
+ share/doc/%%PYTHON_VERSION%%/lib/about.html
++share/doc/%%PYTHON_VERSION%%/lib/abstract-basic-auth-handler.html
++share/doc/%%PYTHON_VERSION%%/lib/abstract-digest-auth-handler.html
+ share/doc/%%PYTHON_VERSION%%/lib/addresslist-objects.html
+@@ -262,2 +210,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/audio-device-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/base-handler-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/binhex-notes.html
+@@ -276,2 +225,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/bytecodes.html
++share/doc/%%PYTHON_VERSION%%/lib/cacheftp-handler-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/cd-parser-objects.html
+@@ -289,8 +239,29 @@
+ share/doc/%%PYTHON_VERSION%%/lib/curses-functions.html
++share/doc/%%PYTHON_VERSION%%/lib/curses-panel-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/curses-textpad-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/curses-window-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/cursespanel-functions.html
+ share/doc/%%PYTHON_VERSION%%/lib/dbhash-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/debugger-commands.html
++share/doc/%%PYTHON_VERSION%%/lib/difflib-examples.html
+ share/doc/%%PYTHON_VERSION%%/lib/dircmp-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/dl-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-accessor-methods.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-attr-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-attributelist-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-comment-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-conformance.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-document-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-documenttype-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-element-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-example.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-exceptions.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-implementation-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-node-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-nodelist-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-pi-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-text-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/dom-type-mapping.html
++share/doc/%%PYTHON_VERSION%%/lib/domeventstream-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/dtd-handler-objects.html
+@@ -300,4 +271,7 @@
+ share/doc/%%PYTHON_VERSION%%/lib/examples-imp.html
++share/doc/%%PYTHON_VERSION%%/lib/expat-content-models.html
+ share/doc/%%PYTHON_VERSION%%/lib/expat-errors.html
+ share/doc/%%PYTHON_VERSION%%/lib/expat-example.html
++share/doc/%%PYTHON_VERSION%%/lib/expaterror-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/file-handler-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/form-objects.html
+@@ -306,7 +280,17 @@
+ share/doc/%%PYTHON_VERSION%%/lib/forms-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/fpectl-example.html
+ share/doc/%%PYTHON_VERSION%%/lib/front.html
++share/doc/%%PYTHON_VERSION%%/lib/ftp-handler-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/ftp-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/genindex.html
++share/doc/%%PYTHON_VERSION%%/lib/gopher-handler.html
+ share/doc/%%PYTHON_VERSION%%/lib/handle-object.html
+ share/doc/%%PYTHON_VERSION%%/lib/html-parser-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/http-basic-auth-handler.html
++share/doc/%%PYTHON_VERSION%%/lib/http-digest-auth-handler.html
++share/doc/%%PYTHON_VERSION%%/lib/http-handler-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/http-password-mgr.html
++share/doc/%%PYTHON_VERSION%%/lib/http-redirect-handler.html
++share/doc/%%PYTHON_VERSION%%/lib/httplib-examples.html
++share/doc/%%PYTHON_VERSION%%/lib/https-handler-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/imap4-example.html
+@@ -317,2 +301,6 @@
+ share/doc/%%PYTHON_VERSION%%/lib/input-source-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/inspect-classes-functions.html
++share/doc/%%PYTHON_VERSION%%/lib/inspect-source.html
++share/doc/%%PYTHON_VERSION%%/lib/inspect-stack.html
++share/doc/%%PYTHON_VERSION%%/lib/inspect-types.html
+ share/doc/%%PYTHON_VERSION%%/lib/internet.html
+@@ -321,2 +309,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/language.html
++share/doc/%%PYTHON_VERSION%%/lib/legacy-unit-tests.html
+ share/doc/%%PYTHON_VERSION%%/lib/lib.css
+@@ -334,2 +323,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/mimetools-message-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/minidom-and-dom.html
+ share/doc/%%PYTHON_VERSION%%/lib/misc.html
+@@ -386,2 +376,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-curses.html
++share/doc/%%PYTHON_VERSION%%/lib/module-curses.panel.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-curses.textpad.html
+@@ -390,2 +381,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-dbm.html
++share/doc/%%PYTHON_VERSION%%/lib/module-difflib.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-dircache.html
+@@ -393,2 +385,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-dl.html
++share/doc/%%PYTHON_VERSION%%/lib/module-doctest.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-dumbdbm.html
+@@ -405,2 +398,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-formatter.html
++share/doc/%%PYTHON_VERSION%%/lib/module-fpectl.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-fpformat.html
+@@ -426,2 +420,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-imp.html
++share/doc/%%PYTHON_VERSION%%/lib/module-inspect.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-jpeg.html
+@@ -514,3 +509,5 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-unicodedata.html
++share/doc/%%PYTHON_VERSION%%/lib/module-unittest.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-urllib.html
++share/doc/%%PYTHON_VERSION%%/lib/module-urllib2.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-urlparse.html
+@@ -518,3 +515,5 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-uu.html
++share/doc/%%PYTHON_VERSION%%/lib/module-warnings.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-wave.html
++share/doc/%%PYTHON_VERSION%%/lib/module-weakref.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-webbrowser.html
+@@ -524,2 +523,5 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-xdrlib.html
++share/doc/%%PYTHON_VERSION%%/lib/module-xml.dom.html
++share/doc/%%PYTHON_VERSION%%/lib/module-xml.dom.minidom.html
++share/doc/%%PYTHON_VERSION%%/lib/module-xml.dom.pulldom.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-xml.parsers.expat.html
+@@ -530,2 +532,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/module-xmllib.html
++share/doc/%%PYTHON_VERSION%%/lib/module-xreadlines.html
+ share/doc/%%PYTHON_VERSION%%/lib/module-zipfile.html
+@@ -541,37 +544,50 @@
+ share/doc/%%PYTHON_VERSION%%/lib/nntp-objects.html
+-share/doc/%%PYTHON_VERSION%%/lib/node128.html
+-share/doc/%%PYTHON_VERSION%%/lib/node141.html
+-share/doc/%%PYTHON_VERSION%%/lib/node144.html
+-share/doc/%%PYTHON_VERSION%%/lib/node145.html
+-share/doc/%%PYTHON_VERSION%%/lib/node146.html
+-share/doc/%%PYTHON_VERSION%%/lib/node147.html
+-share/doc/%%PYTHON_VERSION%%/lib/node148.html
+-share/doc/%%PYTHON_VERSION%%/lib/node149.html
+-share/doc/%%PYTHON_VERSION%%/lib/node150.html
+-share/doc/%%PYTHON_VERSION%%/lib/node151.html
+-share/doc/%%PYTHON_VERSION%%/lib/node152.html
+-share/doc/%%PYTHON_VERSION%%/lib/node153.html
+-share/doc/%%PYTHON_VERSION%%/lib/node154.html
+-share/doc/%%PYTHON_VERSION%%/lib/node155.html
+-share/doc/%%PYTHON_VERSION%%/lib/node215.html
+-share/doc/%%PYTHON_VERSION%%/lib/node216.html
+-share/doc/%%PYTHON_VERSION%%/lib/node222.html
+-share/doc/%%PYTHON_VERSION%%/lib/node241.html
+-share/doc/%%PYTHON_VERSION%%/lib/node243.html
+-share/doc/%%PYTHON_VERSION%%/lib/node244.html
+-share/doc/%%PYTHON_VERSION%%/lib/node245.html
+-share/doc/%%PYTHON_VERSION%%/lib/node246.html
+-share/doc/%%PYTHON_VERSION%%/lib/node247.html
+-share/doc/%%PYTHON_VERSION%%/lib/node252.html
+-share/doc/%%PYTHON_VERSION%%/lib/node366.html
+-share/doc/%%PYTHON_VERSION%%/lib/node376.html
+-share/doc/%%PYTHON_VERSION%%/lib/node377.html
+-share/doc/%%PYTHON_VERSION%%/lib/node413.html
+-share/doc/%%PYTHON_VERSION%%/lib/node422.html
+-share/doc/%%PYTHON_VERSION%%/lib/node423.html
+-share/doc/%%PYTHON_VERSION%%/lib/node424.html
+-share/doc/%%PYTHON_VERSION%%/lib/node425.html
+-share/doc/%%PYTHON_VERSION%%/lib/node427.html
+-share/doc/%%PYTHON_VERSION%%/lib/node80.html
++share/doc/%%PYTHON_VERSION%%/lib/node100.html
++share/doc/%%PYTHON_VERSION%%/lib/node109.html
++share/doc/%%PYTHON_VERSION%%/lib/node110.html
++share/doc/%%PYTHON_VERSION%%/lib/node111.html
++share/doc/%%PYTHON_VERSION%%/lib/node112.html
++share/doc/%%PYTHON_VERSION%%/lib/node113.html
++share/doc/%%PYTHON_VERSION%%/lib/node114.html
++share/doc/%%PYTHON_VERSION%%/lib/node115.html
++share/doc/%%PYTHON_VERSION%%/lib/node116.html
++share/doc/%%PYTHON_VERSION%%/lib/node167.html
++share/doc/%%PYTHON_VERSION%%/lib/node183.html
++share/doc/%%PYTHON_VERSION%%/lib/node186.html
++share/doc/%%PYTHON_VERSION%%/lib/node187.html
++share/doc/%%PYTHON_VERSION%%/lib/node188.html
++share/doc/%%PYTHON_VERSION%%/lib/node189.html
++share/doc/%%PYTHON_VERSION%%/lib/node190.html
++share/doc/%%PYTHON_VERSION%%/lib/node191.html
++share/doc/%%PYTHON_VERSION%%/lib/node192.html
++share/doc/%%PYTHON_VERSION%%/lib/node193.html
++share/doc/%%PYTHON_VERSION%%/lib/node194.html
++share/doc/%%PYTHON_VERSION%%/lib/node195.html
++share/doc/%%PYTHON_VERSION%%/lib/node196.html
++share/doc/%%PYTHON_VERSION%%/lib/node197.html
++share/doc/%%PYTHON_VERSION%%/lib/node255.html
++share/doc/%%PYTHON_VERSION%%/lib/node256.html
++share/doc/%%PYTHON_VERSION%%/lib/node262.html
++share/doc/%%PYTHON_VERSION%%/lib/node281.html
++share/doc/%%PYTHON_VERSION%%/lib/node283.html
++share/doc/%%PYTHON_VERSION%%/lib/node284.html
++share/doc/%%PYTHON_VERSION%%/lib/node285.html
++share/doc/%%PYTHON_VERSION%%/lib/node286.html
++share/doc/%%PYTHON_VERSION%%/lib/node287.html
++share/doc/%%PYTHON_VERSION%%/lib/node312.html
++share/doc/%%PYTHON_VERSION%%/lib/node392.html
++share/doc/%%PYTHON_VERSION%%/lib/node393.html
++share/doc/%%PYTHON_VERSION%%/lib/node40.html
++share/doc/%%PYTHON_VERSION%%/lib/node454.html
++share/doc/%%PYTHON_VERSION%%/lib/node464.html
++share/doc/%%PYTHON_VERSION%%/lib/node465.html
++share/doc/%%PYTHON_VERSION%%/lib/node501.html
++share/doc/%%PYTHON_VERSION%%/lib/node510.html
++share/doc/%%PYTHON_VERSION%%/lib/node511.html
++share/doc/%%PYTHON_VERSION%%/lib/node512.html
++share/doc/%%PYTHON_VERSION%%/lib/node513.html
++share/doc/%%PYTHON_VERSION%%/lib/node515.html
+ share/doc/%%PYTHON_VERSION%%/lib/obsolete-modules.html
++share/doc/%%PYTHON_VERSION%%/lib/opener-director-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/operator-map.html
+ share/doc/%%PYTHON_VERSION%%/lib/os-fd-ops.html
+@@ -597,2 +613,5 @@
+ share/doc/%%PYTHON_VERSION%%/lib/profile.html
++share/doc/%%PYTHON_VERSION%%/lib/proxy-basic-auth-handler.html
++share/doc/%%PYTHON_VERSION%%/lib/proxy-digest-auth-handler.html
++share/doc/%%PYTHON_VERSION%%/lib/proxy-handler.html
+ share/doc/%%PYTHON_VERSION%%/lib/pyclbr-class-objects.html
+@@ -604,5 +623,6 @@
+ share/doc/%%PYTHON_VERSION%%/lib/reporting-bugs.html
++share/doc/%%PYTHON_VERSION%%/lib/request-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/restricted.html
+ share/doc/%%PYTHON_VERSION%%/lib/rlock-objects.html
+-share/doc/%%PYTHON_VERSION%%/lib/rng-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/sax-error-handler.html
+ share/doc/%%PYTHON_VERSION%%/lib/sax-exception-objects.html
+@@ -610,2 +630,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/semaphore-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/sequence-matcher.html
+ share/doc/%%PYTHON_VERSION%%/lib/sgi.html
+@@ -629,2 +650,7 @@
+ share/doc/%%PYTHON_VERSION%%/lib/termios_Example.html
++share/doc/%%PYTHON_VERSION%%/lib/test-concept-classes.html
++share/doc/%%PYTHON_VERSION%%/lib/testcase-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/testresult-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/testrunner-objects.html
++share/doc/%%PYTHON_VERSION%%/lib/testsuite-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/thread-objects.html
+@@ -646,4 +672,12 @@
+ share/doc/%%PYTHON_VERSION%%/lib/undoc.html
++share/doc/%%PYTHON_VERSION%%/lib/unittest-contents.html
+ share/doc/%%PYTHON_VERSION%%/lib/unix.html
++share/doc/%%PYTHON_VERSION%%/lib/unknown-handler-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/urlopener-objs.html
++share/doc/%%PYTHON_VERSION%%/lib/warning-categories.html
++share/doc/%%PYTHON_VERSION%%/lib/warning-filter.html
++share/doc/%%PYTHON_VERSION%%/lib/warning-functions.html
++share/doc/%%PYTHON_VERSION%%/lib/weakref-example.html
++share/doc/%%PYTHON_VERSION%%/lib/weakref-extension.html
++share/doc/%%PYTHON_VERSION%%/lib/weakref-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/writer-impls.html
+@@ -654,2 +688,3 @@
+ share/doc/%%PYTHON_VERSION%%/lib/xml-namespace.html
++share/doc/%%PYTHON_VERSION%%/lib/xmlparser-objects.html
+ share/doc/%%PYTHON_VERSION%%/lib/xmlreader-objects.html
+@@ -688,2 +723,3 @@
+ share/doc/%%PYTHON_VERSION%%/mac/module-Cm.html
++share/doc/%%PYTHON_VERSION%%/mac/module-ColorPicker.html
+ share/doc/%%PYTHON_VERSION%%/mac/module-Ctl.html
+@@ -776,2 +812,3 @@
+ share/doc/%%PYTHON_VERSION%%/ref/datamodel.html
++share/doc/%%PYTHON_VERSION%%/ref/defintions.html
+ share/doc/%%PYTHON_VERSION%%/ref/del.html
+@@ -779,2 +816,3 @@
+ share/doc/%%PYTHON_VERSION%%/ref/dict.html
++share/doc/%%PYTHON_VERSION%%/ref/dynamic-features.html
+ share/doc/%%PYTHON_VERSION%%/ref/exceptions.html
+@@ -793,2 +831,4 @@
+ share/doc/%%PYTHON_VERSION%%/ref/function.html
++share/doc/%%PYTHON_VERSION%%/ref/future-statements.html
++share/doc/%%PYTHON_VERSION%%/ref/futures.html
+ share/doc/%%PYTHON_VERSION%%/ref/genindex.html
+@@ -813,2 +853,4 @@
+ share/doc/%%PYTHON_VERSION%%/ref/logical.html
++share/doc/%%PYTHON_VERSION%%/ref/module-future.html
++share/doc/%%PYTHON_VERSION%%/ref/nested-scopes.html
+ share/doc/%%PYTHON_VERSION%%/ref/notation.html
+@@ -845,2 +887,3 @@
+ share/doc/%%PYTHON_VERSION%%/ref/unary.html
++share/doc/%%PYTHON_VERSION%%/ref/unicode.html
+ share/doc/%%PYTHON_VERSION%%/ref/while.html