aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-05-27 23:58:02 +0800
committerperky <perky@FreeBSD.org>2004-05-27 23:58:02 +0800
commit203aeb85578a1c8f6834e577b7453cfc0cccd36d (patch)
tree63334e2a73b02adb1ce84ed8a37f3a914430e6ae /lang/python/Makefile
parent2648f4641a90e1f71be1af9a0fae404737ddddb4 (diff)
downloadfreebsd-ports-gnome-203aeb85578a1c8f6834e577b7453cfc0cccd36d.tar.gz
freebsd-ports-gnome-203aeb85578a1c8f6834e577b7453cfc0cccd36d.tar.zst
freebsd-ports-gnome-203aeb85578a1c8f6834e577b7453cfc0cccd36d.zip
- Update to Python 2.3.4.
- Test WITHOUT_* instead of WITH_* for values which are on by default so that package build clusters detect correctly.
Diffstat (limited to 'lang/python/Makefile')
-rw-r--r--lang/python/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 149b35f9877d..59648c58b0c8 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3.3
-PORTREVISION= 5
+PORTVERSION= 2.3.4
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -40,12 +39,12 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
- UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Uses python's internal malloc" on
.include <bsd.port.pre.mk>
-.if defined(WITH_THREADS)
+.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
.if defined(WITHOUT_HUGE_STACK_SIZE)
@@ -61,7 +60,7 @@ CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
.endif # defined(WITH_THREADS)
-.if defined(WITHOUT_UCS2)
+.if !defined(WITHOUT_UCS4) && !defined(WITH_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif