aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-07-10 01:18:00 +0800
committerperky <perky@FreeBSD.org>2004-07-10 01:18:00 +0800
commitc449b850a0b8bb369562e672ca1a6ab510665a04 (patch)
treec853d9c23c5bd17dead9b0db5885aae5e1f7ae0c /lang/python/Makefile
parentb3f7c0d5bc5dbb0a364d02679efd645ccff5c175 (diff)
downloadfreebsd-ports-gnome-c449b850a0b8bb369562e672ca1a6ab510665a04.tar.gz
freebsd-ports-gnome-c449b850a0b8bb369562e672ca1a6ab510665a04.tar.zst
freebsd-ports-gnome-c449b850a0b8bb369562e672ca1a6ab510665a04.zip
Allow to install and use 3rd party packages in X11BASE.
${X11BASE}/lib/{python2.3{,/site-packages},site-python} will be added to your python's sys.path if each directory exists. Suggested by: marcus
Diffstat (limited to 'lang/python/Makefile')
-rw-r--r--lang/python/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 9591ae05d10a..be8add20da11 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.4
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -121,6 +122,9 @@ pre-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
+ ${REINPLACE_CMD} -e \
+ 's|^\(prefixes = .*\)\]$$|\1, "${X11BASE}"]|g' \
+ ${WRKSRC}/Lib/site.py
post-configure: ${STACKLESS_POST_CONFIGURE}
@# prepare a subdir for shared build