aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python20
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-06-02 19:42:56 +0800
committertg <tg@FreeBSD.org>1997-06-02 19:42:56 +0800
commite7d66d4cbe52bae1facbcee151783b1933533b52 (patch)
treee458c86488382c3d65717bfec09370348e74aebd /lang/python20
parent1f62c7f71aa743a524f4b53869487137e2b1aef8 (diff)
downloadfreebsd-ports-gnome-e7d66d4cbe52bae1facbcee151783b1933533b52.tar.gz
freebsd-ports-gnome-e7d66d4cbe52bae1facbcee151783b1933533b52.tar.zst
freebsd-ports-gnome-e7d66d4cbe52bae1facbcee151783b1933533b52.zip
Compile with thread support, if libc_r exists and WITH_THREADS is set.
Submitted by: Peter Haight <peterh@prognet.com>
Diffstat (limited to 'lang/python20')
-rw-r--r--lang/python20/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/lang/python20/Makefile b/lang/python20/Makefile
index a7380d8190ee..328328c89ddb 100644
--- a/lang/python20/Makefile
+++ b/lang/python20/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.13 1997/04/20 13:19:11 wosch Exp $
+# $Id: Makefile,v 1.14 1997/05/14 07:35:11 tg Exp $
#
DISTNAME= python1.4
@@ -25,8 +25,20 @@ MAKE_FLAGS+= 'OPT=${CFLAGS}'
INSTALL_TARGET= install
MAN1= python.1
+#
+# If you want to use Python's thread module, you need to set WITH_THREADS
+# to 'yes', and you must have the FreeBSD threading c library (libc_r)
+# installed. See 'man 3 pthread' for details on libc_r.
+#
+WITH_THREADS= yes
+SETUP_FILE= 'Setup'
+.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
+CONFIGURE_ARGS= --with-thread
+SETUP_FILE= 'Setup.thread'
+.endif
+
post-configure:
- ${CP} ${FILESDIR}/Setup ${WRKSRC}/Modules
+ ${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
post-install:
strip ${PREFIX}/bin/python