aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python21
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2003-04-14 03:20:43 +0800
committeralane <alane@FreeBSD.org>2003-04-14 03:20:43 +0800
commit160cefd59609a7f9cb47263a22b7e0a1b3a750a1 (patch)
treee3f8b0740a8d21006f3c8e6c75b4ff930a330bf9 /lang/python21
parent3e386c9519c06bbec7c1418caf74697aff934464 (diff)
downloadfreebsd-ports-gnome-160cefd59609a7f9cb47263a22b7e0a1b3a750a1.tar.gz
freebsd-ports-gnome-160cefd59609a7f9cb47263a22b7e0a1b3a750a1.tar.zst
freebsd-ports-gnome-160cefd59609a7f9cb47263a22b7e0a1b3a750a1.zip
committed zwiki thread stack patch
Diffstat (limited to 'lang/python21')
-rw-r--r--lang/python21/Makefile2
-rw-r--r--lang/python21/files/zwiki.patch23
2 files changed, 24 insertions, 1 deletions
diff --git a/lang/python21/Makefile b/lang/python21/Makefile
index 0c3b95f14e5c..1dd999fd0cb0 100644
--- a/lang/python21/Makefile
+++ b/lang/python21/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python
MASTER_SITES= http://www.python.org/ftp/python/${PORTVERSION}/ \
${MASTER_SITE_SOURCEFORGE} \
diff --git a/lang/python21/files/zwiki.patch b/lang/python21/files/zwiki.patch
new file mode 100644
index 000000000000..af6eba31e6b6
--- /dev/null
+++ b/lang/python21/files/zwiki.patch
@@ -0,0 +1,23 @@
+diff -ruN Python/thread_pthread.h.orig Python/thread_pthread.h
+--- Python/thread_pthread.h.orig Wed Feb 5 01:26:59 2003
++++ Python/thread_pthread.h Wed Feb 5 01:28:32 2003
+@@ -128,6 +128,10 @@
+ {
+ pthread_t th;
+ int success;
++ pthread_attr_t pta;
++ pthread_attr_init(&pta);
++ pthread_attr_setstacksize(&pta, (1<<17));
++
+ #ifdef PTHREAD_SYSTEM_SCHED_SUPPORTED
+ pthread_attr_t attrs;
+ #endif
+@@ -156,7 +160,7 @@
+ #ifdef PTHREAD_SYSTEM_SCHED_SUPPORTED
+ &attrs,
+ #else
+- (pthread_attr_t*)NULL,
++ (pthread_attr_t*)&pta,
+ #endif
+ (void* (*)(void *))func,
+ (void *)arg