aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python23
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2002-06-14 19:19:13 +0800
committertg <tg@FreeBSD.org>2002-06-14 19:19:13 +0800
commit4821829ef7b67d7a1f1742c85afa4357eaeeffd5 (patch)
tree9075e0ce2e7a034b78ae1d425dd52674f8224b97 /lang/python23
parentf85da8706b71233f67602db59caec838d76aeee4 (diff)
downloadfreebsd-ports-gnome-4821829ef7b67d7a1f1742c85afa4357eaeeffd5.tar.gz
freebsd-ports-gnome-4821829ef7b67d7a1f1742c85afa4357eaeeffd5.tar.zst
freebsd-ports-gnome-4821829ef7b67d7a1f1742c85afa4357eaeeffd5.zip
Use new PYTHONPREFIX_*DIR variables to make these ports PREFIX-clean.
Diffstat (limited to 'lang/python23')
-rw-r--r--lang/python23/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index b37625756592..c0af2958abb7 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -76,20 +76,20 @@ PLATFORMS=plat-freebsd3 plat-freebsd4 plat-freebsd5
pre-install:
.for platform in ${PLATFORMS}
- ${MKDIR} ${PYTHON_LIBDIR}/${platform}
+ ${MKDIR} ${PYTHONPREFIX_LIBDIR}/${platform}
.for file in IN.py regen
${INSTALL_DATA} ${WRKSRC}/Lib/${platform}/${file} \
- ${PYTHON_LIBDIR}/${platform}/
+ ${PYTHONPREFIX_LIBDIR}/${platform}/
.endfor
.endfor
post-install:
- @${MKDIR} ${PREFIX}/share/emacs/site-lisp
- ${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
- @${MKDIR} ${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el \
+ ${PREFIX}/share/emacs/site-lisp
+ @${MKDIR} ${PYTHONPREFIX_SITELIBDIR}
.if !defined(NOPORTDOCS)
@cd ${WRKSRC}; tar -c --exclude='*CVS*' -f - Tools | \
- (cd ${PYTHON_LIBDIR}; tar xf -)
+ (cd ${PYTHONPREFIX_LIBDIR}; tar xf -)
@${MKDIR} ${DEMODIR}
@cd ${WRKSRC}/Demo; tar -c --exclude='*CVS*' -f - * | \
(cd ${DEMODIR}; tar xf -)
an> * Fix the build of xorg related ports when the base system is compiled withzeising2012-07-301-0/+4 * - Update to 0.15.0scheidell2012-06-188-26/+26 * Teach the KMS intel driver how the KMS i915 kernel module in head is named.kwm2012-06-072-1/+13 * Convert to new options frameworkbapt2012-05-311-7/+8 * Fix pkglistkevlo2012-05-182-4/+1 * Unbreak by upgrading to 0.9.mi2012-05-072-9/+3 * - Mark BROKEN: bad plistpav2012-05-031-0/+2 * - Fix patchingpav2012-05-036-410/+0 * Fix patching by removing a obsolete patch.kwm2012-04-221-11/+0 * - Please welcome Xorg 7.5.2miwi2012-04-22103-190/+382 * Mark as deprecated and set expiration to 2012-05-10 for ports that are mark a...bapt2012-04-101-0/+3 * - Unbreak portscheidell2012-03-1311-435/+132 * Remove whitespace after b.p.m to help reduce false postives when searching fo...eadler2012-02-082-2/+0 * - Add WWWmiwi2012-02-041-0/+2 * In the rc.d scripts, change assignments to rcvar to use thedougb2012-01-141-1/+1 * Update to 6.14.3eadler2012-01-132-3/+3 * Both of these ports have been BROKEN for nearly a year; it is time to get rid...eadler2012-01-089-66/+0 * - These two ports will soon be deleted so remove them from the meta port.eadler2012-01-081-2/+0 * - Connect xf86-video-intel29 to the buildpav2011-11-181-0/+1 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-0949-49/+0 * - Fix build on FreeBSD 10.0miwi2011-10-2949-5/+49 * Remove more tags from pkg-descr files fo the form:dougb2011-10-243-9/+0 * - Return my ports back to the pool. I was unable to make any fixes tostas2011-10-241-1/+1 * Update to 6.14.2.kwm2011-07-193-46/+3 * Add a patch to UMS supportkwm2011-03-272-0/+43 * - Update to 6.14.1miwi2011-03-254-59/+3 * - Get Rid MD5 supportmiwi2011-03-1933-34/+0 * Remove patch that is causing trouble for users of specific ATI cards.kwm2011-03-092-12/+1 * Replace a custom ARCH check in Mk/bsd.xorg.mk for xf86-video-sunffb withkwm2011-03-012-1/+1 * - Restore BROKEN does not buildmiwi2011-02-284-0/+8 * - Fix fetchmiwi2011-02-272-1/+1 * Update distinfo to unbreak build.kwm2011-02-261-3/+2 * - Add some missing patchesmiwi2011-02-263-0/+67 * - Connect xf86-video-ati613 to the buildmiwi2011-02-261-0/+1 * - Bump PORTREVISION after xorg updatemiwi2011-02-261-7/+2 * - Bump PORTREVISION after xorg updatemiwi2011-02-261-1/+0 * - Please welcome Xorg 7.5.1miwi2011-02-26130-580/+202 * Update from 11.0.1 to 11.0.3 as the former crashes under the modern Xorgmi2011-01-072-4/+3 * - Update to 6.13.2pgollucci2010-12-284-8/+8 * Sync to new bsd.autotools.mkade2010-12-042-2/+2 * Punt autoconf267->autoconf268ade2010-10-161-1/+1 * Round one migration of ports from automake{19,110} to automake111ade2010-10-061-2/+2 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-161-2/+2 * Update to 11.0.1.jsa2010-08-133-4/+6 * Update to 12.6.9.jsa2010-08-132-4/+5 * - Mark BROKEN on 6.X: does not compilepav2010-07-241-0/+4 * - Unbreak with Xorg 1.7Xmiwi2010-07-103-24/+412 * Update from 0.1 to 0.2.osa2010-07-022-8/+7 * Mark ignore, useless without uep(4).osa2010-06-171-1/+8 * Add X.Org xf86-input-egalax driver, version 0.1.osa2010-06-025-0/+34 * Update to 1.2.1 in order to unbreak the build with X.org 7.5.marius2010-05-312-5/+4 * - Mark BROKEN on 6.X: does not compilepav2010-05-261-1/+7 * - Mark BROKEN on 6.X/amd64: does not compilepav2010-05-241-1/+7 * - Mark BROKEN: does not compilepav2010-05-243-0/+6 * - Mark BROKEN: does not compilepav2010-05-131-0/+2 * Pull in patch from git to fix BIOS read on 650 and 760rnoland2010-05-102-0/+12 * - Update to 2.1.17miwi2010-05-102-5/+5 * - Fix build on 6.Xmiwi2010-05-0734-33/+236 * - Fix build on 6.Xmiwi2010-05-0712-11/+84 * - Update to 12.6.7 (which also fix build on new xorg)miwi2010-05-062-5/+11 * Pull patches from git to fix build on newer Xorg.rnoland2010-05-042-1/+71 * Update to 1.4.1 (fix build with newer Xorg)rnoland2010-05-042-5/+4 * Pull patch from git to allow building with newer Xorg.rnoland2010-05-042-1/+76 * Add another patch to fix unresolved symbols.rnoland2010-05-042-1/+81 * - Update to Xorg 7.5miwi2010-05-01120-263/+1202 * - Add port for xf86-video-rdc, X.Org driver forstas2010-04-155-0/+36 * - Remove all broken Drivermiwi2010-03-271-9/+7 * x11-drivers/xf86-input-calcomp Unmaintained upstream. Notify x11 Maintainers...miwi2010-03-2749-403/+0