aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python24
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-07-04 19:57:54 +0800
committerperky <perky@FreeBSD.org>2003-07-04 19:57:54 +0800
commit7660b40c76ab90a99356a65af1b81f4893ab3e91 (patch)
treea34e659674a4a62db10b5882746a2247ea65ed25 /lang/python24
parent68e5bf91d506792ab1e222e14445abad2f31438a (diff)
downloadfreebsd-ports-gnome-7660b40c76ab90a99356a65af1b81f4893ab3e91.tar.gz
freebsd-ports-gnome-7660b40c76ab90a99356a65af1b81f4893ab3e91.tar.zst
freebsd-ports-gnome-7660b40c76ab90a99356a65af1b81f4893ab3e91.zip
o Utilize MASTER_SITE_PYTHON.
o Rename pydoc to pydoc${PORTVERSION} to avoid conflicts among these ports. (lang/python port keeps both of bin/pydoc and bin/pydoc2.2) o Set LATEST_LINK to ${PYTHON_VERSION:S/.//} except lang/python. Now, we can install all of these python versions together cleanly.
Diffstat (limited to 'lang/python24')
-rw-r--r--lang/python24/Makefile12
-rw-r--r--lang/python24/pkg-plist1
2 files changed, 9 insertions, 4 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 925b95221a30..9452e873bea3 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,11 +7,10 @@
PORTNAME= python
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES= lang python ipv6
-MASTER_SITES= http://www.python.org/ftp/python/${PORTVERSION}/ \
- ${MASTER_SITE_SOURCEFORGE} \
- http://SunSITE.Informatik.RWTH-Aachen.DE/python/ftp/python/${PORTVERSION}/
-MASTER_SITE_SUBDIR= python
+MASTER_SITES= ${MASTER_SITE_PYTHON}
+MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org
@@ -86,7 +85,12 @@ pre-install:
.endfor
.endfor
+post-extract:
+ ${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
+ ${WRKSRC}/Tools/scripts/pydoc > ${WRKDIR}/pydoc2.2
+
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.2 ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el \
${PREFIX}/share/emacs/site-lisp
@${MKDIR} ${PYTHONPREFIX_SITELIBDIR}
diff --git a/lang/python24/pkg-plist b/lang/python24/pkg-plist
index a9d86488e2d8..654d269f1cc3 100644
--- a/lang/python24/pkg-plist
+++ b/lang/python24/pkg-plist
@@ -1,4 +1,5 @@
bin/pydoc
+bin/pydoc2.2
bin/python
bin/%%PYTHON_VERSION%%
include/%%PYTHON_VERSION%%/Python.h