aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python25
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-11-13 21:22:34 +0800
committertg <tg@FreeBSD.org>2000-11-13 21:22:34 +0800
commitf4903d52390cc33aa715e23b608e072c1430a4c6 (patch)
tree8690c2f0ffd9ddd0b8503c61ea2ddae20f694690 /lang/python25
parentcacb70c53e0d487d512dba547fb752c8758945e2 (diff)
downloadfreebsd-ports-gnome-f4903d52390cc33aa715e23b608e072c1430a4c6.tar.gz
freebsd-ports-gnome-f4903d52390cc33aa715e23b608e072c1430a4c6.tar.zst
freebsd-ports-gnome-f4903d52390cc33aa715e23b608e072c1430a4c6.zip
Fix compilation on FreeBSD-3.x.
PR: 22226 Reviewed by: Alan Bawden <Alan@LCS.MIT.EDU>
Diffstat (limited to 'lang/python25')
-rw-r--r--lang/python25/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif