aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python25
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2002-06-14 19:19:13 +0800
committertg <tg@FreeBSD.org>2002-06-14 19:19:13 +0800
commit4821829ef7b67d7a1f1742c85afa4357eaeeffd5 (patch)
tree9075e0ce2e7a034b78ae1d425dd52674f8224b97 /lang/python25
parentf85da8706b71233f67602db59caec838d76aeee4 (diff)
downloadfreebsd-ports-gnome-4821829ef7b67d7a1f1742c85afa4357eaeeffd5.tar.gz
freebsd-ports-gnome-4821829ef7b67d7a1f1742c85afa4357eaeeffd5.tar.zst
freebsd-ports-gnome-4821829ef7b67d7a1f1742c85afa4357eaeeffd5.zip
Use new PYTHONPREFIX_*DIR variables to make these ports PREFIX-clean.
Diffstat (limited to 'lang/python25')
-rw-r--r--lang/python25/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index b37625756592..c0af2958abb7 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -76,20 +76,20 @@ PLATFORMS=plat-freebsd3 plat-freebsd4 plat-freebsd5
pre-install:
.for platform in ${PLATFORMS}
- ${MKDIR} ${PYTHON_LIBDIR}/${platform}
+ ${MKDIR} ${PYTHONPREFIX_LIBDIR}/${platform}
.for file in IN.py regen
${INSTALL_DATA} ${WRKSRC}/Lib/${platform}/${file} \
- ${PYTHON_LIBDIR}/${platform}/
+ ${PYTHONPREFIX_LIBDIR}/${platform}/
.endfor
.endfor
post-install:
- @${MKDIR} ${PREFIX}/share/emacs/site-lisp
- ${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
- @${MKDIR} ${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el \
+ ${PREFIX}/share/emacs/site-lisp
+ @${MKDIR} ${PYTHONPREFIX_SITELIBDIR}
.if !defined(NOPORTDOCS)
@cd ${WRKSRC}; tar -c --exclude='*CVS*' -f - Tools | \
- (cd ${PYTHON_LIBDIR}; tar xf -)
+ (cd ${PYTHONPREFIX_LIBDIR}; tar xf -)
@${MKDIR} ${DEMODIR}
@cd ${WRKSRC}/Demo; tar -c --exclude='*CVS*' -f - * | \
(cd ${DEMODIR}; tar xf -)